CVE-2026-27622
CVE-2026-27622 · OpenEXR CompositeDeepScanLine integer-overflow leads to heap OOB write
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In CompositeDeepScanLine::readPixels, per-pixel totals are accumulated in vector<unsigned int> total_sizes for attacker-controlled large counts across many parts, total_sizes[ptr] wraps modulo 2^32. overall_sample_count is then derived from wrapped totals and used in samples[channel].resize(overall_sample_count). Decode pointer setup/consumption proceeds with true sample counts, and write operations in core unpack (generic_unpack_deep_pointers) overrun the undersized composite sample buffer. This vulnerability is fixed in v3.2.6, v3.3.8, and v3.4.6.
CVSS 8.4 · Élevée · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
openexr
- Versions du logiciel
- >= 2.3.0, < 3.2.6: Concernée
- >= 3.3.0, < 3.3.8: Concernée
- >= 3.4.0, < 3.4.6: Concernée
Aucun correctif publié
openexr Debian:12
- Versions du logiciel
- 3.1.13-1
- 3.1.13-2
- 3.1.5-5
- 3.1.5-5.1
- 3.1.5-5.1+hurd.1
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openexr Debian:13
- Versions du logiciel
- 3.1.13-2
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openexr Debian:14
- Versions du logiciel
- 3.1.13-2
- Plages de versions concernées
- ECOSYSTEM: < 3.4.6+ds-1
Mettez à jour vers 3.4.6+ds-1
openexr PyPI
- Versions du logiciel
- 3.2.3
- 3.2.4
- 3.2.5
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.3.0, < 3.2.6
Mettez à jour vers 3.2.6
openexr PyPI
- Versions du logiciel
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.3.0, < 3.3.8
Mettez à jour vers 3.3.8
openexr PyPI
- Versions du logiciel
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.4.0, < 3.4.6
Mettez à jour vers 3.4.6
openexr PyPI
- Versions du logiciel
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.3.0, < 3.2.6 ∪ ≥ 3.3.0, < 3.3.8 ∪ ≥ 3.4.0, < 3.4.6
Mettez à jour vers 3.2.6; Mettez à jour vers 3.3.8; Mettez à jour vers 3.4.6
openexr Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 2.2.0-1ubuntu3
- 2.2.0-7ubuntu1
- 2.2.0-9ubuntu1
- 2.2.0-10ubuntu2
- 2.2.0-10ubuntu2.1
- 2.2.0-10ubuntu2.2
- 2.2.0-10ubuntu2.3
- 2.2.0-10ubuntu2.4
- 2.2.0-10ubuntu2.6
- 2.2.0-10ubuntu2.6+esm1
- 2.2.0-10ubuntu2.6+esm2
- 2.2.0-10ubuntu2.6+esm3
- Plages de versions concernées
- ECOSYSTEM: < 2.2.0-10ubuntu2.6+esm4
Mettez à jour vers 2.2.0-10ubuntu2.6+esm4
openexr Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 2.2.0-11ubuntu1
- 2.2.0-11.1ubuntu1
- 2.2.0-11.1ubuntu1.1
- 2.2.0-11.1ubuntu1.2
- 2.2.0-11.1ubuntu1.3
- 2.2.0-11.1ubuntu1.4
- 2.2.0-11.1ubuntu1.6
- 2.2.0-11.1ubuntu1.7
- 2.2.0-11.1ubuntu1.8
- 2.2.0-11.1ubuntu1.9
- Plages de versions concernées
- ECOSYSTEM: < 2.2.0-11.1ubuntu1.9+esm1
Mettez à jour vers 2.2.0-11.1ubuntu1.9+esm1
openexr Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 2.2.1-4.1ubuntu1
- 2.3.0-6
- 2.3.0-6build1
- 2.3.0-6ubuntu0.1
- 2.3.0-6ubuntu0.2
- 2.3.0-6ubuntu0.3
- 2.3.0-6ubuntu0.5
- 2.3.0-6ubuntu0.5+esm1
- Plages de versions concernées
- ECOSYSTEM: < 2.3.0-6ubuntu0.5+esm2
Mettez à jour vers 2.3.0-6ubuntu0.5+esm2
openexr Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 2.5.4-2
- 2.5.7-1
- 2.5.7-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: < 2.5.7-1ubuntu0.1~esm2
Mettez à jour vers 2.5.7-1ubuntu0.1~esm2
openexr Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 3.1.5-5.1
- 3.1.5-5.1build1
- 3.1.5-5.1build2
- 3.1.5-5.1build3
- Plages de versions concernées
- ECOSYSTEM: < 3.1.5-5.1ubuntu0.1~esm1
Mettez à jour vers 3.1.5-5.1ubuntu0.1~esm1
openexr Ubuntu:25.10
- Versions du logiciel
- 3.1.13-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openexr Ubuntu:Pro:26.04:LTS
- Versions du logiciel
- 3.1.13-2
- 3.1.13-2build1
- Plages de versions concernées
- ECOSYSTEM: < 3.1.13-2ubuntu0.26.04.1~esm1
Mettez à jour vers 3.1.13-2ubuntu0.26.04.1~esm1
Sources originales
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-cr4v-6jm6-4963
- https://access.redhat.com/security/cve/CVE-2026-27622
- https://bugzilla.redhat.com/show_bug.cgi?id=2444251
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-27622.json
- https://access.redhat.com/errata/RHSA-2026:7678
- https://access.redhat.com/errata/RHSA-2026:7682
- https://access.redhat.com/errata/RHSA-2026:8863
- https://access.redhat.com/errata/RHSA-2026:12340
- https://access.redhat.com/errata/RHSA-2026:12341
- https://access.redhat.com/errata/RHSA-2026:12339
- https://access.redhat.com/errata/RHSA-2026:12338
- https://access.redhat.com/errata/RHSA-2026:8870
- https://access.redhat.com/errata/RHSA-2026:8869
- https://access.redhat.com/errata/RHSA-2026:8871
- https://access.redhat.com/errata/RHSA-2026:8872
- https://access.redhat.com/errata/RHSA-2026:8888
- https://access.redhat.com/errata/RHSA-2026:16008
- https://access.redhat.com/errata/RHSA-2026:16030
- https://access.redhat.com/errata/RHSA-2026:16009
- https://access.redhat.com/errata/RHSA-2026:16174
- https://nvd.nist.gov/vuln/detail/CVE-2026-27622