CVE-2026-32600
CVE-2026-32600 · xml-security is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
xml-security is a library that implements XML signatures and encryption. Prior to versions 2.3.1 and 1.13.9, XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. This vulnerability is fixed in 2.3.1 and 1.13.9.
CVSS 8.2 · Élevée · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
xml-security
- Versions du logiciel
- >= 2.0.0, < 2.3.1: Concernée
- < 1.13.9: Concernée
Aucun correctif publié
simplesamlphp/xml-security Packagist
- Versions du logiciel
- v2.0.0
- v2.0.1
- v2.0.2
- v2.0.3
- v2.0.4
- v2.0.5
- v2.0.6
- v2.0.7
- v2.0.8
- v2.0.9
- v2.1.0
- v2.1.1
- v2.1.2
- v2.2.0
- v2.3.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.0.0, < 2.3.1
Mettez à jour vers 2.3.1
simplesamlphp/xml-security Packagist
- Versions du logiciel
- v0.0.1
- v0.0.10
- v0.0.11
- v0.0.2
- v0.0.3
- v0.0.4
- v0.0.5
- v0.0.6
- v0.0.7
- v0.0.8
- v0.0.9
- v0.1.0
- v0.1.1
- v0.2.0
- v0.2.1
- v0.2.2
- v0.2.3
- v0.2.4
- v0.2.5
- v0.2.6
- v0.2.7
- v0.3.0
- v0.3.1
- v0.3.2
- v0.3.3
- v0.4.0
- v0.4.1
- v0.4.2
- v0.4.3
- v0.4.4
- v0.4.5
- v0.4.6
- v0.4.7
- v0.5.0
- v0.5.1
- v0.5.2
- v0.5.3
- v0.5.4
- v0.5.5
- v0.5.6
- v0.5.7
- v0.6.0
- v0.6.1
- v0.6.2
- v0.6.3
- v0.6.4
- v0.6.5
- v0.6.6
- v1.0.0
- v1.0.1
- v1.0.2
- v1.0.3
- v1.0.4
- v1.0.5
- v1.0.6
- v1.0.7
- v1.0.8
- v1.1.0
- v1.1.1
- v1.1.2
- v1.10.0
- v1.11.0
- v1.11.1
- v1.11.2
- v1.12.0
- v1.12.1
- v1.13.0
- v1.13.1
- v1.13.2
- v1.13.3
- v1.13.4
- v1.13.5
- v1.13.6
- v1.13.7
- v1.13.8
- v1.2.0
- v1.5.0
- v1.5.1
- v1.6.0
- v1.6.1
- v1.6.10
- v1.6.11
- v1.6.12
- v1.6.2
- v1.6.3
- v1.6.4
- v1.6.5
- v1.6.6
- v1.6.7
- v1.6.8
- v1.6.9
- v1.7.0
- v1.7.1
- v1.7.2
- v1.7.3
- v1.7.4
- v1.7.5
- v1.7.6
- v1.8.0
- v1.8.1
- v1.8.2
- v1.8.3
- v1.8.4
- v1.8.5
- v1.8.6
- v1.8.7
- v1.9.0
- v1.9.1
- v1.9.2
- v1.9.3
- v1.9.4
- v1.9.5
- v1.9.6
- Plages de versions concernées
- ECOSYSTEM: < 1.13.9
Mettez à jour vers 1.13.9
Sources originales
- https://github.com/simplesamlphp/xml-security/security/advisories/GHSA-r353-4845-pr5p
- https://github.com/simplesamlphp/xml-security/commit/cad6d57cf0a5a0b7e0cc4e4a5b18752e56eb1520
- https://github.com/simplesamlphp/xml-security/commit/fdc12449e959c610943f9fd428e95e3832d74c25
- https://nvd.nist.gov/vuln/detail/CVE-2026-32600