CVE-2026-32773
CVE-2026-32773 · Apache Spark: XSS Vulnerability in Spark Web 3.5.4
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.
CVSS 6.1 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
apache spark
- Versions du logiciel
- ≥ 3.0.0, < 3.5.8: Concernée (semver)
Mettez à jour vers 3.5.8
pyspark PyPI
- Versions du logiciel
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.5.0
- 3.5.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.5.5
- 3.5.6
- 3.5.7
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.0.0, < 3.5.8
Mettez à jour vers 3.5.8
org.apache.spark:spark-core_2.12 Maven
- Versions du logiciel
- 3.0.0
- 3.0.0-preview
- 3.0.0-preview2
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.5.0
- 3.5.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.5.5
- 3.5.6
- 3.5.7
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.0.0, < 3.5.8
Mettez à jour vers 3.5.8
org.apache.spark:spark-core_2.13 Maven
- Versions du logiciel
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.5.0
- 3.5.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.5.5
- 3.5.6
- 3.5.7
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.0.0, < 3.5.8
Mettez à jour vers 3.5.8