CVE-2026-32871
CVE-2026-32871 · FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
FastMCP is a Pythonic way to build MCP servers and clients. Prior to version 3.2.0, the OpenAPIProvider in FastMCP exposes internal APIs to MCP clients by parsing OpenAPI specifications. The RequestDirector class is responsible for constructing HTTP requests to the backend service. A vulnerability exists in the _build_url() method. When an OpenAPI operation defines path parameters (e.g., /api/v1/users/{user_id}), the system directly substitutes parameter values into the URL template string without URL-encoding. Subsequently, urllib.parse.urljoin() resolves the final URL. Since urljoin() interprets ../ sequences as directory traversal, an attacker controlling a path parameter can perform path traversal attacks to escape the intended API prefix and access arbitrary backend endpoints. This results in authenticated SSRF, as requests are sent with the authorization headers configured in the MCP provider. This issue has been patched in version 3.2.0.
CVSS 10.0 · Critique · EPSS 0,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
fastmcp
- Versions du logiciel
- < 3.2.0: Concernée
Aucun correctif publié
fastmcp PyPI
- Versions du logiciel
- 0.1.0
- 0.2.0
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.4.0
- 0.4.1
- 1.0
- 2.0.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.10.0
- 2.10.1
- 2.10.2
- 2.10.3
- 2.10.4
- 2.10.5
- 2.10.6
- 2.11.0
- 2.11.1
- 2.11.2
- 2.11.3
- 2.12.0
- 2.12.0rc1
- 2.12.1
- 2.12.2
- 2.12.3
- 2.12.4
- 2.12.5
- 2.13.0
- 2.13.0.1
- 2.13.0.2
- 2.13.0rc1
- 2.13.0rc2
- 2.13.0rc3
- 2.13.1
- 2.13.2
- 2.13.3
- 2.14.0
- 2.14.1
- 2.14.2
- 2.14.3
- 2.14.4
- 2.14.5
- 2.14.6
- 2.14.7
- 2.2.0
- 2.2.1
- 2.2.10
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.3.0
- 2.3.0rc1
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.4.0
- 2.5.0
- 2.5.1
- 2.5.2
- 2.6.0
- 2.6.1
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.9.0
- 2.9.1
- 2.9.2
- 3.0.0
- 3.0.0b1
- 3.0.0b2
- 3.0.0rc1
- 3.0.0rc2
- 3.0.0rc3
- 3.0.1
- 3.0.2
- 3.1.0
- 3.1.1
- Plages de versions concernées
- ECOSYSTEM: < 3.2.0
Mettez à jour vers 3.2.0
Sources originales
- https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-vv7q-7jx5-f767
- https://github.com/PrefectHQ/fastmcp/pull/3507
- https://github.com/PrefectHQ/fastmcp/commit/40bdfb6b1de0ce30609ee9ba5bb95ecd04a9fb71
- https://github.com/PrefectHQ/fastmcp/releases/tag/v3.2.0
- https://access.redhat.com/security/cve/CVE-2026-32871
- https://bugzilla.redhat.com/show_bug.cgi?id=2454434
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32871.json
- https://access.redhat.com/errata/RHSA-2026:36350
- https://nvd.nist.gov/vuln/detail/CVE-2026-32871