CVE-2026-32874
CVE-2026-32874 · UltraJSON has a Memory Leak parsing large integers allows DoS
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. Versions 5.4.0 through 5.11.0 contain an accumulating memory leak in JSON parsing large (outside of the range [-2^63, 2^64 - 1]) integers. The leaked memory is a copy of the string form of the integer plus an additional NULL byte. The leak occurs irrespective of whether the integer parses successfully or is rejected due to having more than sys.get_int_max_str_digits() digits, meaning that any sized leak per malicious JSON can be achieved provided that there is no limit on the overall size of the payload. Any service that calls ujson.load()/ujson.loads()/ujson.decode() on untrusted inputs is affected and vulnerable to denial of service attacks. This issue has been fixed in version 5.12.0.
CVSS 7.5 · Élevée · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
ultrajson
- Versions du logiciel
- >= 5.4.0, < 5.12.0: Concernée
Aucun correctif publié
ujson Debian:12
- Versions du logiciel
- 5.10.0-1
- 5.11.0-1
- 5.11.0-2
- 5.11.0-3
- 5.13.0-1
- 5.7.0-1
- 5.8.0-1
- 5.9.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ujson Debian:13
- Versions du logiciel
- 5.10.0-1
- 5.11.0-1
- 5.11.0-2
- 5.11.0-3
- 5.13.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ujson Debian:14
- Versions du logiciel
- 5.10.0-1
- 5.11.0-1
- 5.11.0-2
- 5.11.0-3
- Plages de versions concernées
- ECOSYSTEM: < 5.13.0-1
Mettez à jour vers 5.13.0-1
ujson PyPI
- Versions du logiciel
- 5.10.0
- 5.11.0
- 5.4.0
- 5.5.0
- 5.6.0
- 5.7.0
- 5.8.0
- 5.9.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 5.4.0, < 5.12.0
Mettez à jour vers 5.12.0
ujson Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 5.8.0-1
- 5.8.0-1build1
- 5.9.0-1
- 5.9.0-1build1
- Plages de versions concernées
- ECOSYSTEM: < 5.9.0-1ubuntu0.1~esm1
Mettez à jour vers 5.9.0-1ubuntu0.1~esm1
ujson Ubuntu:25.10
- Versions du logiciel
- 5.10.0-1build2
- Plages de versions concernées
- ECOSYSTEM: < 5.10.0-1ubuntu0.1
Mettez à jour vers 5.10.0-1ubuntu0.1
ujson Ubuntu:26.10
- Versions du logiciel
- 5.11.0-3build1
- 5.13.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ujson Ubuntu:26.04:LTS
- Versions du logiciel
- 5.10.0-1build2
- 5.10.0-1build3
- 5.11.0-3
- 5.11.0-3build1
- Plages de versions concernées
- ECOSYSTEM: < 5.11.0-3ubuntu0.1
Mettez à jour vers 5.11.0-3ubuntu0.1
Sources originales
- https://github.com/ultrajson/ultrajson/security/advisories/GHSA-wgvc-ghv9-3pmm
- https://github.com/ultrajson/ultrajson/commit/4baeb950df780092bd3c89fc702a868e99a3a1d2
- https://github.com/ultrajson/ultrajson/releases/tag/5.12.0
- https://access.redhat.com/security/cve/CVE-2026-32874
- https://bugzilla.redhat.com/show_bug.cgi?id=2449411
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32874.json
- https://nvd.nist.gov/vuln/detail/CVE-2026-32874