CVE-2026-34757
CVE-2026-34757 · LIBPNG has a yse-after-free in png_set_PLTE, png_set_tRNS and png_set_hIST leading to corrupted chunk data and potential heap information disclosure
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From 1.0.9 to before 1.6.57, passing a pointer obtained from png_get_PLTE, png_get_tRNS, or png_get_hIST back into the corresponding setter on the same png_struct/png_info pair causes the setter to read from freed memory and copy its contents into the replacement buffer. The setter frees the internal buffer before copying from the caller-supplied pointer, which now dangles. The freed region may contain stale data (producing silently corrupted chunk metadata) or data from subsequent heap allocations (leaking unrelated heap contents into the chunk struct). This vulnerability is fixed in 1.6.57.
CVSS 5.1 · Moyenne · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
libpng
- Versions du logiciel
- >= 1.0.9, < 1.6.57: Concernée
Aucun correctif publié
libpng1.6 Debian:12
- Versions du logiciel
- 1.6.39-2
- 1.6.39-2+deb12u1
- 1.6.39-2+deb12u2
- 1.6.39-2+deb12u3
- 1.6.39-2+deb12u4
- Plages de versions concernées
- ECOSYSTEM: < 1.6.39-2+deb12u5
Mettez à jour vers 1.6.39-2+deb12u5
libpng1.6 Debian:13
- Versions du logiciel
- 1.6.48-1
- 1.6.48-1+deb13u1
- 1.6.48-1+deb13u2
- 1.6.48-1+deb13u3
- 1.6.48-1+deb13u4
- Plages de versions concernées
- ECOSYSTEM: < 1.6.48-1+deb13u5
Mettez à jour vers 1.6.48-1+deb13u5
libpng1.6 Debian:14
- Versions du logiciel
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- 1.6.51-1
- 1.6.52-1
- 1.6.53-1
- 1.6.54-1
- 1.6.55-1
- 1.6.56-1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.57-1
Mettez à jour vers 1.6.57-1
libpng Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1.2.49-4ubuntu1
- 1.2.49-5ubuntu1
- 1.2.50-1ubuntu1
- 1.2.50-1ubuntu2
- 1.2.50-1ubuntu2.14.04.1
- 1.2.50-1ubuntu2.14.04.2
- 1.2.50-1ubuntu2.14.04.3
- 1.2.50-1ubuntu2.14.04.3+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1.2.50-1ubuntu2.14.04.3+esm2
Mettez à jour vers 1.2.50-1ubuntu2.14.04.3+esm2
libpng Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.2.51-0ubuntu3
- 1.2.54-1
- 1.2.54-1ubuntu1
- 1.2.54-1ubuntu1.1
- 1.2.54-1ubuntu1.1+esm1
- 1.2.54-1ubuntu1.1+esm2
- Plages de versions concernées
- ECOSYSTEM: < 1.2.54-1ubuntu1.1+esm3
Mettez à jour vers 1.2.54-1ubuntu1.1+esm3
libpng1.6 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.6.20-2
- 1.6.20-2ubuntu0.1~esm1
- 1.6.20-2ubuntu0.1~esm2
- 1.6.20-2ubuntu0.1~esm3
- Plages de versions concernées
- ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm4
Mettez à jour vers 1.6.20-2ubuntu0.1~esm4
libpng1.6 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.6.34-1
- 1.6.34-1ubuntu0.18.04.1
- 1.6.34-1ubuntu0.18.04.2
- 1.6.34-1ubuntu0.18.04.2+esm1
- 1.6.34-1ubuntu0.18.04.2+esm2
- Plages de versions concernées
- ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm3
Mettez à jour vers 1.6.34-1ubuntu0.18.04.2+esm3
libpng1.6 Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1.6.37-1
- 1.6.37-2
- 1.6.37-2ubuntu0.1~esm1
- 1.6.37-2ubuntu0.1~esm2
- Plages de versions concernées
- ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm3
Mettez à jour vers 1.6.37-2ubuntu0.1~esm3
libpng1.6 Ubuntu:22.04:LTS
- Versions du logiciel
- 1.6.37-3build4
- 1.6.37-3build5
- 1.6.37-3ubuntu0.1
- 1.6.37-3ubuntu0.3
- 1.6.37-3ubuntu0.4
- Plages de versions concernées
- ECOSYSTEM: < 1.6.37-3ubuntu0.5
Mettez à jour vers 1.6.37-3ubuntu0.5
libpng1.6 Ubuntu:24.04:LTS
- Versions du logiciel
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- 1.6.43-5ubuntu0.1
- 1.6.43-5ubuntu0.3
- 1.6.43-5ubuntu0.4
- 1.6.43-5ubuntu0.5
- Plages de versions concernées
- ECOSYSTEM: < 1.6.43-5ubuntu0.6
Mettez à jour vers 1.6.43-5ubuntu0.6
libpng1.6 Ubuntu:25.10
- Versions du logiciel
- 1.6.47-1.1
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1~exp1
- 1.6.50-1
- 1.6.50-1ubuntu0.1
- 1.6.50-1ubuntu0.3
- 1.6.50-1ubuntu0.4
- Plages de versions concernées
- ECOSYSTEM: < 1.6.50-1ubuntu0.5
Mettez à jour vers 1.6.50-1ubuntu0.5
Sources originales
- https://github.com/pnggroup/libpng/security/advisories/GHSA-6fr7-g8h7-v645
- https://github.com/pnggroup/libpng/issues/836
- https://github.com/pnggroup/libpng/issues/837
- https://github.com/pnggroup/libpng/commit/398cbe3df03f4e11bb031e07f416dfdde3684e8a
- https://github.com/pnggroup/libpng/commit/55d20aaa322c9274491cda82c5cd4f99b48c6bcc
- https://lists.debian.org/debian-lts-announce/2026/05/msg00017.html
- https://nvd.nist.gov/vuln/detail/CVE-2026-34757