CVE-2026-39960
CVE-2026-39960 · MantisBT is Vulnerable to Stored XSS through Custom Field Textarea Values
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.28.1 and below contain flawed logic that causes improper escaping of a textarea custom field's contents in the Update Issue page, (bug_update_page.php) allowing an attacker to inject HTML and, if CSP settings permit, execute arbitrary JavaScript when the page is loaded. This facilitates session theft, leading to admin account takeover, full project data access. In order to exploit this issue, a textarea-type custom field must be configured for the project, the attack must be carried out by an authenticated user with bug report permission (low privilege). This can affect any user viewing the bug edit form, including administrators. The issue has been fixed in version 2.28.2. If users cannot immediately upgrade, they can work around the issue by using the default Content-Security Policy, which blocks script execution.
CVSS 5.4 · Moyenne · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
mantisbt
- Versions du logiciel
- < 2.28.2: Concernée
Aucun correctif publié
mantisbt/mantisbt Packagist
- Versions du logiciel
- 2.10.0
- 2.10.1
- 2.11.0
- 2.11.1
- 2.12.0
- 2.12.1
- 2.12.2
- 2.13.0
- 2.13.1
- 2.13.2
- 2.14.0
- 2.15.0
- 2.15.1
- 2.16.0
- 2.16.1
- 2.17.0
- 2.17.1
- 2.17.2
- 2.18.0
- 2.18.1
- 2.19.0
- 2.19.1
- 2.20.0
- 2.20.1
- 2.21.0
- 2.21.1
- 2.21.2
- 2.21.3
- 2.22.0
- 2.22.1
- 2.22.2
- 2.23.0
- 2.23.1
- 2.24.0
- 2.24.1
- 2.24.2
- 2.24.3
- 2.24.4
- 2.24.5
- 2.25.0
- 2.25.1
- 2.25.2
- 2.25.3
- 2.25.4
- 2.25.5
- 2.25.6
- 2.25.7
- 2.25.8
- 2.26.0
- 2.26.1
- 2.26.2
- 2.26.3
- 2.26.4
- 2.27.0
- 2.27.1
- 2.27.2
- 2.27.3
- 2.28.0
- 2.28.1
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.4.0
- 2.4.1
- 2.4.2
- 2.5.0
- 2.5.1
- 2.5.2
- 2.6.0
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.9.0
- 2.9.1
- Plages de versions concernées
- ECOSYSTEM: < 2.28.2
Mettez à jour vers 2.28.2