CVE-2026-42584
CVE-2026-42584 · Netty: HttpClientCodec response desynchronization
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, HttpClientCodec pairs each inbound response with an outbound request by queue.poll() once per response, including for 1xx. If the client pipelines GET then HEAD and the server sends 103, then 200 with GET body, then 200 for HEAD, the queue pairs HEAD with the first 200. The HEAD rule then skips reading that message’s body, so the GET entity bytes stay on the stream and the following 200 is parsed from the wrong offset. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
CVSS 7.3 · Élevée · EPSS 0,8% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
netty
- Versions du logiciel
- >= 4.2.0.Alpha1, < 4.2.13.Final: Concernée
- < 4.1.133.Final: Concernée
Aucun correctif publié
netty-codec-http
- Versions du logiciel
- >= 4.2.0.Alpha1, < 4.2.13.Final: Concernée
- < 4.1.133.Final: Concernée
Aucun correctif publié
netty Debian:12
- Versions du logiciel
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- 1:4.1.48-16
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- 1:4.1.48-7+deb12u2
- 1:4.1.48-8
- 1:4.1.48-9
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
netty Debian:13
- Versions du logiciel
- 1:4.1.48-10
- 1:4.1.48-10+deb13u1
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- 1:4.1.48-16
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
netty Debian:14
- Versions du logiciel
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-15
- 1:4.1.48-16
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
netty Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- Plages de versions concernées
- ECOSYSTEM: < 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
Mettez à jour vers 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
netty Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- 1:4.0.34-1ubuntu0.1~esm1
- 1:4.0.34-1ubuntu0.1~esm2
- 1:4.0.34-1ubuntu0.1~esm3
- Plages de versions concernées
- ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm4
Mettez à jour vers 1:4.0.34-1ubuntu0.1~esm4
netty Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- 1:4.1.7-4ubuntu0.1+esm3
- 1:4.1.7-4ubuntu0.1+esm4
- 1:4.1.7-4ubuntu0.1+esm5
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm6
Mettez à jour vers 1:4.1.7-4ubuntu0.1+esm6
netty Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- 1:4.1.45-1ubuntu0.1~esm2
- 1:4.1.45-1ubuntu0.1~esm3
- 1:4.1.45-1ubuntu0.1~esm4
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm6
Mettez à jour vers 1:4.1.45-1ubuntu0.1~esm6
netty Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- 1:4.1.48-4+deb11u2ubuntu0.1~esm1
- 1:4.1.48-4+deb11u2ubuntu0.1~esm2
- 1:4.1.48-4+deb11u2ubuntu0.1
- 1:4.1.48-4+deb11u2ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.1+esm3
Mettez à jour vers 1:4.1.48-4+deb11u2ubuntu0.1+esm3
netty Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- 1:4.1.48-9ubuntu0.1~esm1
- 1:4.1.48-9ubuntu0.1~esm2
- 1:4.1.48-9ubuntu0.1
- 1:4.1.48-9ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.1+esm3
Mettez à jour vers 1:4.1.48-9ubuntu0.1+esm3
netty Ubuntu:25.10
- Versions du logiciel
- 1:4.1.48-10
- 1:4.1.48-10ubuntu0.25.10.1
- 1:4.1.48-10ubuntu0.25.10.2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
netty Ubuntu:26.10
- Versions du logiciel
- 1:4.1.48-16
- 1:4.1.48-16ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
netty Ubuntu:Pro:26.04:LTS
- Versions du logiciel
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-16
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-16ubuntu0.1~esm2
Mettez à jour vers 1:4.1.48-16ubuntu0.1~esm2
Sources originales
- https://github.com/netty/netty/security/advisories/GHSA-57rv-r2g8-2cj3
- https://access.redhat.com/security/cve/CVE-2026-42584
- https://bugzilla.redhat.com/show_bug.cgi?id=2477224
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42584.json
- https://access.redhat.com/errata/RHSA-2026:49700
- https://access.redhat.com/errata/RHSA-2026:53644
- https://access.redhat.com/errata/RHSA-2026:53645
- https://access.redhat.com/errata/RHSA-2026:28010
- https://access.redhat.com/errata/RHSA-2026:53646
- https://access.redhat.com/errata/RHSA-2026:66545
- https://access.redhat.com/errata/RHSA-2026:66488
- https://access.redhat.com/errata/RHSA-2026:49701
- https://access.redhat.com/errata/RHSA-2026:42644
- https://access.redhat.com/errata/RHSA-2026:65126
- https://access.redhat.com/errata/RHSA-2026:25123
- https://access.redhat.com/errata/RHSA-2026:36820
- https://access.redhat.com/errata/RHSA-2026:37390
- https://access.redhat.com/errata/RHSA-2026:23808
- https://access.redhat.com/errata/RHSA-2026:24502
- https://access.redhat.com/errata/RHSA-2026:54435
- https://nvd.nist.gov/vuln/detail/CVE-2026-42584