p PatchFirst

CVE-2026-44177

CVE-2026-44177 · Kirby: Pre-authentication path traversal and PHP file inclusion during user lookup

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Kirby is an open-source content management system. In versions 5.3.0 and above but prior to 5.4.1, Kirby did not correctly validate the provided user ID, resulting in a path traversal vulnerability. Version 5.3.0 introduced a performance improvement to the Users collection that loaded user objects lazily when first needed. Users were queried by their ID, which was then used to locate the corresponding account directory under site/accounts. This affected the authentication API (accessible to unauthenticated requests), the users API (accessible only to authenticated users), and any other place that uses $users->find() to look up an individual user by a request-provided email or ID. As a result, an attacker could trigger arbitrary PHP file inclusion of files named  index.php (for example, the main PHP files of plugins), the impact of which depends on the logic those files contain. It also allowed probing for the existence of arbitrary directories on the server, letting attackers fingerprint the server and site setup, including installed plugins and the content structure. This issue has been fixed in version 5.4.1.

CVSS 8.8 · Élevée · EPSS 1,8% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • kirby

    Versions du logiciel
    • >= 5.3.0, < 5.4.1: Concernée

    Aucun correctif publié

  • getkirby/cms Packagist

    Versions du logiciel
    • 5.3.0
    • 5.3.1
    • 5.3.2
    • 5.3.3
    • 5.4.0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 5.3.0, < 5.4.1

    Mettez à jour vers 5.4.1

Sources originales

Vérifiez votre serveur →