p PatchFirst

CVE-2026-44578

CVE-2026-44578 · Next.js: Server-side request forgery in applications using WebSocket upgrades

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

CVSS 8.6 · Élevée · EPSS 35,5% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • next.js

    Versions du logiciel
    • >= 16.0.0, < 16.2.5: Concernée
    • >= 13.4.13, < 15.5.16: Concernée

    Aucun correctif publié

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 13.4.13, < 15.5.16

    Mettez à jour vers 15.5.16

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 16.0.0, < 16.2.5

    Mettez à jour vers 16.2.5

Sources originales

Vérifiez votre serveur →