p PatchFirst

CVE-2026-44580

CVE-2026-44580 · Next.js: Cross-site scripting in beforeInteractive scripts with untrusted input

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.

CVSS 6.1 · Moyenne · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • next.js

    Versions du logiciel
    • >= 13.0.0, < 15.5.16: Concernée
    • >= 16.0.0, < 16.2.5: Concernée

    Aucun correctif publié

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 13.0.0, < 15.5.16

    Mettez à jour vers 15.5.16

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 16.0.0, < 16.2.5

    Mettez à jour vers 16.2.5

Sources originales

Vérifiez votre serveur →