p PatchFirst

CVE-2026-46334

CVE-2026-46334 · OpenSIPS: Denial of Service in SDP bandwidth parsing via QoS SDP cloning

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.6.6 and 4.0.0-rc1 contain a denial of service vulnerability in the SDP bandwidth-line parsing logic. A SIP request with Content-Type: application/sdp and a malformed session-level SDP bandwidth line missing the required colon delimiter can corrupt parsed SDP bandwidth metadata. When a route or module subsequently clones the corrupted SDP state, as occurs with dialog and QoS processing, the OpenSIPS worker process crashes. An unauthenticated remote attacker can therefore trigger a crash in any configuration whose routing script parses attacker-controlled SDP and applies dialog/QoS processing. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.

CVSS 8.7 · Élevée · EPSS 0,7%

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • opensips

    Versions du logiciel
    • >= 3.4.0, < 3.6.6: Concernée
    • >= 4.0.0-beta, < 4.0.0-rc1: Concernée

    Aucun correctif publié

  • opensips Ubuntu:18.04:LTS

    Versions du logiciel
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →