CVE-2026-46526
CVE-2026-46526 · Local Deep Research: SSRF bypass in `safe_get`
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Local Deep Research is an AI-powered research assistant for deep, iterative research. Prior to 1.6.10, the URL checking logic in local-deep-research has a logical flaw that could be bypassed by attackers, leading to SSRF attacks. The current project uses validate_url to validate the input URL. The main logic is to perform security checks on the host portion of the URL extracted by urlparse to prevent SSRF attacks. However, there are indeed differences in parsing between urlparse and the library that actually sends the request. For example, in safe_get, validate_url is first used to perform an SSRF check, and then requests.get is used to send the actual request. This vulnerability is fixed in 1.6.10.
CVSS 5.0 · Moyenne · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
local-deep-research
- Versions du logiciel
- < 1.6.10: Concernée
Aucun correctif publié
local-deep-research PyPI
- Versions du logiciel
- 0.1.0
- 0.1.1
- 0.1.12
- 0.1.13
- 0.1.14
- 0.1.15
- 0.1.16
- 0.1.17
- 0.1.18
- 0.1.19
- 0.1.20
- 0.1.21
- 0.1.22
- 0.1.23
- 0.1.24
- 0.1.25
- 0.1.26
- 0.2.0
- 0.2.2
- 0.2.3
- 0.3.0
- 0.3.1
- 0.3.10
- 0.3.11
- 0.3.12
- 0.3.2
- 0.3.3
- 0.3.5
- 0.3.6
- 0.3.8
- 0.3.9
- 0.4.0
- 0.4.1
- 0.4.2
- 0.4.3
- 0.4.4
- 0.5.0
- 0.5.2
- 0.5.3
- 0.5.4
- 0.5.5
- 0.5.6
- 0.5.7
- 0.5.9
- 0.6.0
- 0.6.1
- 0.6.4
- 0.6.5
- 0.6.7
- 1.0.0
- 1.0.1
- 1.1.1
- 1.1.10
- 1.1.11
- 1.1.6
- 1.1.7
- 1.1.8
- 1.1.9
- 1.2.0
- 1.2.1
- 1.2.10
- 1.2.11
- 1.2.12
- 1.2.13
- 1.2.14
- 1.2.15
- 1.2.16
- 1.2.17
- 1.2.2
- 1.2.24
- 1.2.25
- 1.2.26
- 1.2.27
- 1.2.28
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 1.2.8
- 1.2.9
- 1.3.0
- 1.3.1
- 1.3.10
- 1.3.11
- 1.3.12
- 1.3.13
- 1.3.14
- 1.3.15
- 1.3.16
- 1.3.17
- 1.3.18
- 1.3.19
- 1.3.20
- 1.3.21
- 1.3.22
- 1.3.24
- 1.3.25
- 1.3.26
- 1.3.28
- 1.3.29
- 1.3.30
- 1.3.40
- 1.3.41
- 1.3.42
- 1.3.43
- 1.3.44
- 1.3.45
- 1.3.46
- 1.3.47
- 1.3.48
- 1.3.49
- 1.3.50
- 1.3.51
- 1.3.52
- 1.3.53
- 1.3.54
- 1.3.55
- 1.3.56
- 1.3.57
- 1.3.58
- 1.3.59
- 1.3.6
- 1.3.60
- 1.3.7
- 1.3.8
- 1.3.9
- 1.4.0
- 1.5.0
- 1.5.3
- 1.5.5
- 1.5.6
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- Plages de versions concernées
- ECOSYSTEM: < 1.6.10
Mettez à jour vers 1.6.10
Sources originales
- https://github.com/LearningCircuit/local-deep-research/security/advisories/GHSA-g23j-2vwm-5c25
- https://github.com/LearningCircuit/local-deep-research/pull/3873
- https://github.com/LearningCircuit/local-deep-research/pull/3882
- https://github.com/LearningCircuit/local-deep-research/pull/3889
- https://github.com/LearningCircuit/local-deep-research/pull/3932
- https://github.com/LearningCircuit/local-deep-research/releases/tag/v1.6.10
- https://nvd.nist.gov/vuln/detail/CVE-2026-46526