CVE-2026-46703
CVE-2026-46703 · BoxLite: Path Traversal Vulnerability in boxlite Leads to Arbitrary File Write on the Host
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Boxlite is a sandbox service that allows users to create lightweight virtual machines (Boxes) and launch OCI containers within them to run untrusted code. Prior to version 0.9.0, Boxlite allows users to specify the OCI image used by containers in the sandbox. However, when processing tar entries in OCI images, Boxlite does not account for the possibility that entries may be symlinks pointing to absolute paths. An attacker can craft a malicious OCI image and distribute it on image hosting platforms such as DockerHub, tricking users into using it. Once a user loads the malicious image, the attacker can write arbitrary content to any path on the host, which can further lead to remote code execution on the host. This issue has been patched in version 0.9.0.
CVSS 9.6 · Critique · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python · node
Produits et versions concernés
boxlite
- Versions du logiciel
- < 0.9.0: Concernée
Aucun correctif publié
boxlite PyPI
- Versions du logiciel
- 0.5.10
- 0.5.11
- 0.5.12
- 0.5.13
- 0.5.14
- 0.5.9
- 0.6.0
- 0.7.0
- 0.7.4
- 0.7.5
- 0.8.2
- Plages de versions concernées
- ECOSYSTEM: < 0.9.0
Mettez à jour vers 0.9.0
boxlite-cli crates.io
- Plages de versions concernées
- SEMVER: < 0.9.0
Mettez à jour vers 0.9.0
boxlite crates.io
- Plages de versions concernées
- SEMVER: < 0.9.0
Mettez à jour vers 0.9.0
@boxlite-ai/boxlite npm
- Plages de versions concernées
- SEMVER: < 0.9.0
Mettez à jour vers 0.9.0
github.com/boxlite-ai/boxlite/sdks/go Go
- Plages de versions concernées
- SEMVER: < 0.9.0
Mettez à jour vers 0.9.0
boxlite PyPI
- Versions du logiciel
- 0.5.10
- 0.5.11
- 0.5.12
- 0.5.13
- 0.5.14
- 0.5.2
- 0.5.3
- 0.5.4
- 0.5.5
- 0.5.6
- 0.5.7
- 0.5.8
- 0.5.9
- 0.6.0
- 0.7.0
- 0.7.4
- 0.7.5
- 0.8.2
- Plages de versions concernées
- ECOSYSTEM: < 0.9.0
Mettez à jour vers 0.9.0