CVE-2026-47198
CVE-2026-47198 · Paymenter: URL parameter injection bypasses paid plan limits at checkout
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.1, the checkout component improperly filters URL-writable properties, allowing authenticated users to inject arbitrary key-value pairs into server provisioning parameters. Because bundled server extensions prioritize these user-supplied properties over administrator-defined configurations, a regular user can override hosting plans and resource limits at checkout without special privileges. The Checkout Livewire component's $checkoutConfig property exposed via URL query parameters, only validating keys explicitly defined by an extension's configuration method, allowing any undefined injected keys to bypass validation entirely. These unsanitized keys are then stored directly in the database by the cart component and later passed to server extensions during provisioning, enabling user-injected data to override intended administrator settings. Depending on the active extension, this leads to unauthorized overrides of core resource limits (such as CPU, RAM, storage, or package tiers). No administrative privileges are required to exploit this vulnerability. This issue has been fixed in version 1.5.1.
CVSS 8.5 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
paymenter
- Versions du logiciel
- < 1.5.1: Concernée
Aucun correctif publié
paymenter/paymenter Packagist
- Versions du logiciel
- 0.1
- 0.1.1
- 0.1.2
- 0.1.3
- 0.2
- 0.2.1
- v0.3
- v0.4
- v0.4.1
- v0.5
- v0.5.1
- v0.5.2
- v0.5.3
- v0.6
- v0.7
- v0.7.1
- v0.8
- v0.8.1
- v0.8.2
- v0.9
- v0.9.1
- v0.9.2
- v0.9.3
- v0.9.4
- v0.9.5
- v1.0.0
- v1.0.1
- v1.0.2
- v1.0.3
- v1.0.4
- v1.1.0
- v1.1.1
- Plages de versions concernées
- ECOSYSTEM: < 1.5.1
Mettez à jour vers 1.5.1