CVE-2026-4800
CVE-2026-4800 · lodash vulnerable to Code Injection via `_.template` imports key names
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Cette page présente une partie des faits des sources. Consultez les avis liés pour la description complète et les versions concernées.
The fix for CVE-2021-23337 added validation for the variable option in _.template but did not apply the same validation to options.imports key names, and both paths flow into the same Function() constructor sink. When an application passes untrusted input as options.imports key names, an attacker can inject default-parameter expressions that execute arbitrary code at template compilation time. Additionally, _.template uses assignInWith to merge imports, which enumerates inherited properties via for..in, so if Object.prototype has been polluted by another vector the polluted keys are copied into the imports object and passed to Function(). The issue is fixed in 4.18.1 for lodash, lodash-es, lodash-amd, and lodash.template. As a workaround, do not pass untrusted input as key names in options.imports; use only developer-controlled, static key names.
CVSS 8.1 · Élevée · EPSS 2,8% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
lodash
- Versions du logiciel
- ≥ 4.0.0, < 4.18.1: Concernée (semver)
- 4.18.1: Non concernée (semver)
Mettez à jour vers 4.18.1
lodash-es
- Versions du logiciel
- ≥ 4.0.0, < 4.18.1: Concernée (semver)
- 4.18.1: Non concernée (semver)
Mettez à jour vers 4.18.1
lodash-amd
- Versions du logiciel
- ≥ 4.0.0, < 4.18.1: Concernée (semver)
- 4.18.1: Non concernée (semver)
Mettez à jour vers 4.18.1
lodash.template
- Versions du logiciel
- ≥ 4.0.0, < 4.18.1: Concernée (semver)
- 4.18.1: Non concernée (semver)
Mettez à jour vers 4.18.1
node-lodash Debian:12
- Versions du logiciel
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- Plages de versions concernées
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9+deb12u1
Mettez à jour vers 4.17.21+dfsg+~cs8.31.198.20210220-9+deb12u1
node-lodash Debian:13
- Versions du logiciel
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- Plages de versions concernées
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9+deb13u1
Mettez à jour vers 4.17.21+dfsg+~cs8.31.198.20210220-9+deb13u1
node-lodash Debian:14
- Versions du logiciel
- 4.17.21+dfsg+~cs8.31.198.20210220-10
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- 4.17.23+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: < 4.18.1+dfsg-1
Mettez à jour vers 4.18.1+dfsg-1
lodash npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.0, < 4.18.0
Mettez à jour vers 4.18.0
lodash-es npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.0, < 4.18.0
Mettez à jour vers 4.18.0
lodash-amd npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.0, < 4.18.0
Mettez à jour vers 4.18.0
lodash.template npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.0, < 4.18.0
Mettez à jour vers 4.18.0
node-lodash Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 2.4.1+dfsg-3
- Plages de versions concernées
- ECOSYSTEM: < 2.4.1+dfsg-3ubuntu0.1~esm1
Mettez à jour vers 2.4.1+dfsg-3ubuntu0.1~esm1
node-lodash Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 4.17.4+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: < 4.17.4+dfsg-1ubuntu0.1~esm1
Mettez à jour vers 4.17.4+dfsg-1ubuntu0.1~esm1
node-lodash Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 4.17.11+dfsg-4
- 4.17.15+dfsg-2
- Plages de versions concernées
- ECOSYSTEM: < 4.17.15+dfsg-2ubuntu0.1~esm1
Mettez à jour vers 4.17.15+dfsg-2ubuntu0.1~esm1
node-lodash Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 4.17.21+dfsg+~cs8.31.173-1
- 4.17.21+dfsg+~cs8.31.196.20210220-2
- 4.17.21+dfsg+~cs8.31.198.20210220-4
- 4.17.21+dfsg+~cs8.31.198.20210220-5
- Plages de versions concernées
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-5ubuntu0.1~esm1
Mettez à jour vers 4.17.21+dfsg+~cs8.31.198.20210220-5ubuntu0.1~esm1
node-lodash Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- Plages de versions concernées
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.24.04.1~esm1
Mettez à jour vers 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.24.04.1~esm1
node-lodash Ubuntu:25.10
- Versions du logiciel
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- Plages de versions concernées
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.25.10.1
Mettez à jour vers 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.25.10.1
node-lodash Ubuntu:26.10
- Versions du logiciel
- 4.17.23+dfsg-1
- 4.18.1+dfsg-3
- 4.18.1+dfsg1-1
- 4.18.1+dfsg1-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-lodash Ubuntu:Pro:26.04:LTS
- Versions du logiciel
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- 4.17.23+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: < 4.17.23+dfsg-1ubuntu0.1~esm1
Mettez à jour vers 4.17.23+dfsg-1ubuntu0.1~esm1
Sources originales
- https://github.com/lodash/lodash/security/advisories/GHSA-r5fr-rjxr-66jc
- https://cna.openjsf.org/security-advisories.html
- https://access.redhat.com/security/cve/CVE-2026-4800
- https://bugzilla.redhat.com/show_bug.cgi?id=2453496
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-4800.json
- https://access.redhat.com/errata/RHSA-2026:42078
- https://access.redhat.com/errata/RHSA-2026:24762
- https://access.redhat.com/errata/RHSA-2026:17789
- https://access.redhat.com/errata/RHSA-2026:24331
- https://access.redhat.com/errata/RHBA-2026:21387
- https://access.redhat.com/errata/RHSA-2026:34342
- https://access.redhat.com/errata/RHSA-2026:11470
- https://access.redhat.com/errata/RHSA-2026:10713
- https://access.redhat.com/errata/RHSA-2026:19008
- https://access.redhat.com/errata/RHSA-2026:11493
- https://access.redhat.com/errata/RHSA-2026:11494
- https://access.redhat.com/errata/RHSA-2026:11495
- https://access.redhat.com/errata/RHSA-2026:11454
- https://access.redhat.com/errata/RHSA-2026:11469
- https://access.redhat.com/errata/RHSA-2026:11516
- https://access.redhat.com/errata/RHSA-2026:11471
- https://access.redhat.com/errata/RHSA-2026:10710
- https://access.redhat.com/errata/RHSA-2026:19167
- https://nvd.nist.gov/vuln/detail/CVE-2026-4800