CVE-2026-49158
CVE-2026-49158 · Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
CVSS 7.5 · Élevée · EPSS 1,0% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
apache thrift
- Versions du logiciel
- ≥ 0, < 0.24.0: Concernée (semver)
Mettez à jour vers 0.24.0
thrift Debian:12
- Versions du logiciel
- 0.17.0-2
- 0.17.0-3
- 0.17.0-4
- 0.18.1-1
- 0.18.1-2
- 0.19.0-1
- 0.19.0-2
- 0.19.0-2.1
- 0.19.0-2.1~exp1
- 0.19.0-3
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- 0.24.0-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
thrift Debian:13
- Versions du logiciel
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- 0.24.0-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
thrift Debian:14
- Versions du logiciel
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- Plages de versions concernées
- ECOSYSTEM: < 0.24.0-2
Mettez à jour vers 0.24.0-2
ruby-thrift Ubuntu:20.04:LTS
- Versions du logiciel
- 0.11.0.0-2
- 0.11.0.0-2build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ruby-thrift Ubuntu:22.04:LTS
- Versions du logiciel
- 0.11.0.0-3
- 0.14.0-2
- 0.14.0-2build1
- 0.14.0-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ruby-thrift Ubuntu:24.04:LTS
- Versions du logiciel
- 0.16.0-2
- 0.16.0-2build1
- 0.16.0-2build2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié