p PatchFirst

CVE-2026-5079

CVE-2026-5079 · multer vulnerable to Denial of Service via deeply nested field names

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.

CVSS 7.5 · Élevée · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • multer

    Versions du logiciel
    • ≥ 1.0.0, < 2.2.0: Concernée (semver)
    • 2.2.0: Non concernée (semver)
    • ≥ 3.0.0-alpha.1, < 3.0.0-alpha.2: Concernée (semver)
    • 3.0.0-alpha.2: Non concernée (semver)

    Mettez à jour vers 2.2.0; Mettez à jour vers 3.0.0-alpha.2

  • multer npm

    Plages de versions concernées
    • SEMVER: ≥ 1.0.0, < 2.2.0

    Mettez à jour vers 2.2.0

  • multer npm

    Plages de versions concernées
    • SEMVER: ≥ 3.0.0-alpha.1, < 3.0.0-alpha.2

    Mettez à jour vers 3.0.0-alpha.2

Sources originales

Vérifiez votre serveur →