CVE-2026-53586
CVE-2026-53586 · libgit2: HTTP transport can leak credentials to an offsite redirect target
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, the built-in HTTP transport in src/libgit2/transports/http.c follows an offsite initial redirect, and handle_remote_auth and handle_auth pass transport->owner->url instead of transport->server.url to the credential callback when the redirected host returns 401 Unauthorized. A callback that scopes credentials to the original trusted URL can therefore return GIT_CREDENTIAL_USERPASS_PLAINTEXT credentials that libgit2 stores in transport->server.cred and sends as an Authorization header to the redirected host. An attacker who controls a trusted Git host or an open redirect on that host can disclose HTTP Basic credentials, personal access tokens, or equivalent credentials. This issue is fixed in versions 1.8.6 and 1.9.5.
CVSS 6.5 · Moyenne · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
libgit2
- Versions du logiciel
- < 1.8.6: Concernée
- >= 1.9.0, < 1.9.5: Concernée
Aucun correctif publié
libgit2 Debian:12
- Versions du logiciel
- 1.5.1+ds-1
- 1.5.1+ds-1+deb12u1
- Plages de versions concernées
- ECOSYSTEM: < 1.5.1+ds-1+deb12u2
Mettez à jour vers 1.5.1+ds-1+deb12u2
libgit2 Debian:13
- Versions du logiciel
- 1.9.0+ds-2
- Plages de versions concernées
- ECOSYSTEM: < 1.9.0+ds-2+deb13u1
Mettez à jour vers 1.9.0+ds-2+deb13u1
libgit2 Debian:14
- Versions du logiciel
- 1.9.0+ds-2
- 1.9.1+ds-1
- 1.9.2+ds-1
- 1.9.2+ds-2
- 1.9.2+ds-3
- 1.9.2+ds-4
- 1.9.2+ds-5
- 1.9.2+ds-6
- 1.9.2+ds-7
- 1.9.2+ds-8
- 1.9.2+ds-9
- 1.9.3+ds-1
- 1.9.4+ds-1
- Plages de versions concernées
- ECOSYSTEM: < 1.9.6+ds-1
Mettez à jour vers 1.9.6+ds-1
libgit2 Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 0.27.7+dfsg.1-0.2build1
- 0.28.3+dfsg.1-1
- 0.28.3+dfsg.1-1ubuntu1
- 0.28.4+dfsg.1-2
- 0.28.4+dfsg.1-2ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 0.28.4+dfsg.1-2ubuntu0.1+esm1
Mettez à jour vers 0.28.4+dfsg.1-2ubuntu0.1+esm1
libgit2 Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 1.1.0+dfsg.1-4
- 1.1.0+dfsg.1-4.1
- 1.1.0+dfsg.1-4.1build1
- 1.1.0+dfsg.1-4.1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 1.1.0+dfsg.1-4.1ubuntu0.1+esm1
Mettez à jour vers 1.1.0+dfsg.1-4.1ubuntu0.1+esm1
libgit2 Ubuntu:24.04:LTS
- Versions du logiciel
- 1.5.1+ds-1ubuntu1
- 1.7.1+ds-2ubuntu1
- 1.7.2+ds-1ubuntu1
- 1.7.2+ds-1ubuntu2
- 1.7.2+ds-1ubuntu3
- Plages de versions concernées
- ECOSYSTEM: < 1.7.2+ds-1ubuntu3.1
Mettez à jour vers 1.7.2+ds-1ubuntu3.1
libgit2 Ubuntu:26.04:LTS
- Versions du logiciel
- 1.9.0+ds-2ubuntu2
- 1.9.1+ds-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 1.9.1+ds-1ubuntu1.1
Mettez à jour vers 1.9.1+ds-1ubuntu1.1
Sources originales
- https://github.com/libgit2/libgit2/security/advisories/GHSA-2889-x8f6-mc4x
- https://github.com/libgit2/libgit2/commit/07de6a7e438f95ac9a6efd3222a82117e871ed27
- https://github.com/libgit2/libgit2/commit/af2b29ad0a74d5bac9751376879ddaf848136d3b
- https://github.com/libgit2/libgit2/commit/c1507abc44647b3acd832a33a5b1c8c9f5ba8821
- https://github.com/libgit2/libgit2/releases/tag/v1.8.6
- https://github.com/libgit2/libgit2/releases/tag/v1.9.5
- https://nvd.nist.gov/vuln/detail/CVE-2026-53586