CVE-2026-54232
CVE-2026-54232 · vLLM: Dependency Confusion Vulnerability in vLLM Dockerfile
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.
CVSS 8.8 · Élevée · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
vllm
- Versions du logiciel
- < 0.22.1: Concernée
Aucun correctif publié
vllm PyPI
- Versions du logiciel
- 0.0.1
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.10.0
- 0.10.1
- 0.10.1.1
- 0.10.2
- 0.11.0
- 0.11.1
- 0.11.2
- 0.12.0
- 0.13.0
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.16.0
- 0.17.0
- 0.17.1
- 0.18.0
- 0.18.1
- 0.19.0
- 0.19.1
- 0.2.0
- 0.2.1
- 0.2.1.post1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.20.0
- 0.20.1
- 0.20.2
- 0.21.0
- 0.22.0
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.4.0
- 0.4.0.post1
- 0.4.1
- 0.4.2
- 0.4.3
- 0.5.0
- 0.5.0.post1
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.3.post1
- 0.5.4
- 0.5.5
- 0.6.0
- 0.6.1
- 0.6.1.post1
- 0.6.1.post2
- 0.6.2
- 0.6.3
- 0.6.3.post1
- 0.6.4
- 0.6.4.post1
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.5.post1
- 0.9.0
- 0.9.0.1
- 0.9.1
- 0.9.2
- Plages de versions concernées
- ECOSYSTEM: < 0.22.1
Mettez à jour vers 0.22.1