p PatchFirst

CVE-2026-54268

CVE-2026-54268 · Angular: Denial of Service (DoS) via OOM in Date Formatting (formatDate)

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, a Denial of Service (DoS) vulnerability exists in the @angular/common package of the Angular framework. The formatDate function, which is also utilized by the standard Angular DatePipe, does not properly limit or validate the length of the format parameter. When parsing a maliciously crafted, excessively long date format string (e.g., a repeating pattern or very large string), the internal parser splits the string iteratively using a regular expression loop. This results in uncontrolled resource consumption (high CPU utilization and excessive memory allocations), leading to a Denial of Service (DoS). This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.

CVSS 8.2 · Élevée · EPSS 0,6% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • angular

    Versions du logiciel
    • >= 22.0.0-next.0 < 22.0.1: Concernée
    • >= 21.0.0-next.0 < 21.2.17: Concernée
    • >= 20.0.0-next.0 < 20.3.25: Concernée
    • <= 19.2.25: Concernée

    Aucun correctif publié

  • angular.js Debian:12

    Versions du logiciel
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Debian:13

    Versions du logiciel
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • @angular/common npm

    Plages de versions concernées
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.1

    Mettez à jour vers 22.0.1

  • @angular/common npm

    Plages de versions concernées
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.17

    Mettez à jour vers 21.2.17

  • @angular/common npm

    Plages de versions concernées
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.25

    Mettez à jour vers 20.3.25

  • @angular/common npm

    Plages de versions concernées
    • SEMVER: ≤ 19.2.25

    Aucun correctif publié

  • angular.js Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 1.2.28-1ubuntu2
    • 1.2.28-1ubuntu2+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 1.5.10-1
    • 1.5.10-1ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 1.5.10-1
    • 1.7.9-1
    • 1.7.9-1ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.8.2-2
    • 1.8.2-2ubuntu0.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:24.04:LTS

    Versions du logiciel
    • 1.8.3-1
    • 1.8.3-1ubuntu0.24.04.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:25.10

    Versions du logiciel
    • 1.8.3-1
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:26.10

    Versions du logiciel
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:26.04:LTS

    Versions du logiciel
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →