CVE-2026-55599
CVE-2026-55599 · phpseclib: X.509 certificate validation sends attacker-controlled outbound requests (server-side request forgery) via Authority Information Access
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
phpseclib is a PHP secure communications library. From 0.1.1 until 1.0.30, 2.0.55, and 3.0.54, when an application validates an untrusted X.509 certificate with phpseclib, X509::validateSignature() reads a URL out of that certificate's Authority Information Access (AIA) extension and connects to it. Attacker who supplies certificate fully controls host, port, and path of that connection. URL fetching is enabled by default, and no destination is blocked. An unauthenticated attacker can therefore make a validating server open connections to internal hosts and ports it should never reach, for example loopback 127.0.0.1, cloud metadata address 169.254.169.254, and internal-only services. This is a server-side request forgery (SSRF) caused by an insecure default. This vulnerability is fixed in 1.0.30, 2.0.55, and 3.0.54.
CVSS 5.8 · Moyenne · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Produits et versions concernés
phpseclib
- Versions du logiciel
- >= 0.1.1, < 1.0.30: Concernée
- >= 2.0.0, < 2.0.55: Concernée
- >= 3.0.0, < 3.0.54: Concernée
Aucun correctif publié
php-phpseclib Debian:12
- Versions du logiciel
- 2.0.42-1
- 2.0.42-1+deb12u1
- 2.0.42-1+deb12u2
- 2.0.42-1+deb12u3
- 2.0.42-1+deb12u5
- 2.0.44-1
- 2.0.45-1
- 2.0.46-1
- 2.0.47-1
- 2.0.47-2
- 2.0.47-3
- 2.0.48-1
- 2.0.48-2
- 2.0.48-3
- 2.0.49-1
- 2.0.50-1
- 2.0.51-1
- 2.0.52-1
- 2.0.53-1
- 2.0.54-1
- 2.0.55-1
- 3.0.2-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
php-phpseclib Debian:13
- Versions du logiciel
- 2.0.48-3
- 2.0.48-3+deb13u1
- 2.0.48-3+deb13u3
- 2.0.49-1
- 2.0.50-1
- 2.0.51-1
- 2.0.52-1
- 2.0.53-1
- 2.0.54-1
- 2.0.55-1
- 3.0.2-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
php-phpseclib Debian:14
- Versions du logiciel
- 2.0.48-3
- 2.0.49-1
- 2.0.50-1
- 2.0.51-1
- 2.0.52-1
- 2.0.53-1
- 2.0.54-1
- Plages de versions concernées
- ECOSYSTEM: < 2.0.55-1
Mettez à jour vers 2.0.55-1
php-phpseclib3 Debian:12
- Versions du logiciel
- 3.0.19-1
- 3.0.19-1+deb12u1
- 3.0.19-1+deb12u2
- 3.0.19-1+deb12u3
- 3.0.19-1+deb12u4
- 3.0.19-1+deb12u6
- 3.0.20-1
- 3.0.21-1
- 3.0.21-2
- 3.0.22-1
- 3.0.23-1
- 3.0.33-1
- 3.0.34-1
- 3.0.35-1
- 3.0.36-1
- 3.0.37-1
- 3.0.38-1
- 3.0.39-1
- 3.0.41-1
- 3.0.42-1
- 3.0.43-1
- 3.0.43-2
- 3.0.44-1
- 3.0.44-2
- 3.0.45-1
- 3.0.46-1
- 3.0.46-2
- 3.0.47-1
- 3.0.48-1
- 3.0.49-1
- 3.0.50-1
- 3.0.51-1
- 3.0.52-1
- 3.0.52-2
- 3.0.53-1
- 3.0.55-1
- 3.0.56-1
- 3.0.57-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
php-phpseclib3 Debian:13
- Versions du logiciel
- 3.0.43-2
- 3.0.43-2+deb13u1
- 3.0.43-2+deb13u3
- 3.0.44-1
- 3.0.44-2
- 3.0.45-1
- 3.0.46-1
- 3.0.46-2
- 3.0.47-1
- 3.0.48-1
- 3.0.49-1
- 3.0.50-1
- 3.0.51-1
- 3.0.52-1
- 3.0.52-2
- 3.0.53-1
- 3.0.55-1
- 3.0.56-1
- 3.0.57-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
php-phpseclib3 Debian:14
- Versions du logiciel
- 3.0.43-2
- 3.0.44-1
- 3.0.44-2
- 3.0.45-1
- 3.0.46-1
- 3.0.46-2
- 3.0.47-1
- 3.0.48-1
- 3.0.49-1
- 3.0.50-1
- 3.0.51-1
- 3.0.52-1
- 3.0.52-2
- 3.0.53-1
- Plages de versions concernées
- ECOSYSTEM: < 3.0.55-1
Mettez à jour vers 3.0.55-1
phpseclib Debian:12
- Versions du logiciel
- 1.0.20-1
- 1.0.20-1+deb12u1
- 1.0.20-1+deb12u2
- 1.0.20-1+deb12u3
- 1.0.20-1+deb12u5
- 1.0.21-1
- 1.0.21-2
- 1.0.22-1
- 1.0.23-1
- 1.0.23-2
- 1.0.23-3
- 1.0.23-4
- 1.0.23-5
- 1.0.23-6
- 1.0.24-1
- 1.0.27-1
- 1.0.28-1
- 1.0.29-1
- 1.0.30-1
- 2.0.0-1
- 2.0.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
phpseclib Debian:13
- Versions du logiciel
- 1.0.23-6
- 1.0.23-6+deb13u1
- 1.0.23-6+deb13u3
- 1.0.24-1
- 1.0.27-1
- 1.0.28-1
- 1.0.29-1
- 1.0.30-1
- 2.0.0-1
- 2.0.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
phpseclib/phpseclib Packagist
- Versions du logiciel
- 0.3.0
- 0.3.1
- 0.3.10
- 0.3.5
- 0.3.6
- 0.3.7
- 0.3.8
- 0.3.9
- 1.0.0
- 1.0.1
- 1.0.10
- 1.0.11
- 1.0.12
- 1.0.13
- 1.0.14
- 1.0.15
- 1.0.16
- 1.0.17
- 1.0.18
- 1.0.19
- 1.0.2
- 1.0.20
- 1.0.21
- 1.0.22
- 1.0.23
- 1.0.24
- 1.0.25
- 1.0.26
- 1.0.27
- 1.0.28
- 1.0.29
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.0.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 0.1.1, < 1.0.30
Mettez à jour vers 1.0.30
phpseclib/phpseclib Packagist
- Versions du logiciel
- 2.0.0
- 2.0.1
- 2.0.10
- 2.0.11
- 2.0.12
- 2.0.13
- 2.0.14
- 2.0.15
- 2.0.16
- 2.0.17
- 2.0.18
- 2.0.19
- 2.0.2
- 2.0.20
- 2.0.21
- 2.0.22
- 2.0.23
- 2.0.24
- 2.0.25
- 2.0.26
- 2.0.27
- 2.0.28
- 2.0.29
- 2.0.3
- 2.0.30
- 2.0.31
- 2.0.32
- 2.0.33
- 2.0.34
- 2.0.35
- 2.0.36
- 2.0.37
- 2.0.38
- 2.0.39
- 2.0.4
- 2.0.40
- 2.0.41
- 2.0.42
- 2.0.43
- 2.0.44
- 2.0.45
- 2.0.46
- 2.0.47
- 2.0.48
- 2.0.49
- 2.0.5
- 2.0.50
- 2.0.51
- 2.0.52
- 2.0.53
- 2.0.54
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.0.0, < 2.0.55
Mettez à jour vers 2.0.55
phpseclib/phpseclib Packagist
- Versions du logiciel
- 3.0.0
- 3.0.1
- 3.0.10
- 3.0.11
- 3.0.12
- 3.0.13
- 3.0.14
- 3.0.15
- 3.0.16
- 3.0.17
- 3.0.18
- 3.0.19
- 3.0.2
- 3.0.20
- 3.0.21
- 3.0.22
- 3.0.23
- 3.0.3
- 3.0.33
- 3.0.34
- 3.0.35
- 3.0.36
- 3.0.37
- 3.0.38
- 3.0.39
- 3.0.4
- 3.0.40
- 3.0.41
- 3.0.42
- 3.0.43
- 3.0.44
- 3.0.45
- 3.0.46
- 3.0.47
- 3.0.48
- 3.0.49
- 3.0.5
- 3.0.50
- 3.0.51
- 3.0.52
- 3.0.53
- 3.0.6
- 3.0.7
- 3.0.8
- 3.0.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.0.0, < 3.0.54
Mettez à jour vers 3.0.54
phpseclib Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0.3.10-3
- 1.0.0-2
- 1.0.0-3
- 1.0.1-1
- 1.0.1-3
- 1.0.1-3ubuntu0.1
- 1.0.1-3ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
phpseclib Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.0.7-1
- 1.0.8-1
- 1.0.9-1
- 1.0.9-1ubuntu0.1~esm1
- 1.0.9-1ubuntu0.1~esm2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
phpseclib Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1.0.16-2
- 1.0.18-2
- 1.0.18-2ubuntu0.1~esm1
- 1.0.18-2ubuntu0.1~esm2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
phpseclib Ubuntu:22.04:LTS
- Versions du logiciel
- 1.0.19-3ubuntu2
- 1.0.19-3ubuntu3
- 1.0.20-1
- 1.0.20-1ubuntu0.1~esm1
- 1.0.20-1+deb12u3build0.22.04.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
phpseclib Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 1.0.21-2
- 1.0.22-1
- 1.0.23-1
- 1.0.23-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
phpseclib Ubuntu:25.10
- Versions du logiciel
- 1.0.23-6
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
phpseclib Ubuntu:26.10
- Versions du logiciel
- 1.0.24-1
- 1.0.29-1
- 1.0.30-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
phpseclib Ubuntu:Pro:26.04:LTS
- Versions du logiciel
- 1.0.23-6
- 1.0.24-1
- 1.0.24-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié