p PatchFirst

CVE-2026-55855

CVE-2026-55855 · MariaDB Connector/Node.js: Possible SQL injection in Buffer parameter escaping under big5/gbk/sjis/cp932/gb18030 client charsets

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. Prior to 3.2.4, 3.3.3, 3.4.6, and 3.5.3, MariaDB Connector/Node.js permits SQL injection when attacker-controlled Buffer parameters are escaped client-side under the big5, gbk, sjis, cp932, or gb18030 client character sets. PacketOutputStream.writeBufferEscape in lib/io/packet-output-stream.js escaped bytes without the charset-aware getMbRecognizer logic in lib/misc/charset-mb.js. The server SQL lexer runs my_ismbchar before escape processing, so an attacker-controlled lead byte can consume the inserted 0x5C backslash as a multibyte trail byte and leave the following 0x27 quote unescaped, terminating the string literal and allowing arbitrary SQL. The default utf8mb4 character set and parameters sent through the execute binary prepared-statement path are not affected. Successful exploitation can expose or modify data available to the database account. This issue is fixed in versions 3.2.4, 3.3.3, 3.4.6, and 3.5.3.

CVSS 6.5 · Moyenne · EPSS 0,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node · database

Produits et versions concernés

  • mariadb-connector-nodejs

    Versions du logiciel
    • < 3.2.4: Concernée
    • >= 3.3.0, < 3.3.3: Concernée
    • >= 3.4.0, < 3.4.6: Concernée
    • >= 3.5.0, < 3.5.3: Concernée

    Aucun correctif publié

  • mariadb npm

    Plages de versions concernées
    • SEMVER: < 3.2.4

    Mettez à jour vers 3.2.4

  • mariadb npm

    Plages de versions concernées
    • SEMVER: ≥ 3.3.0, < 3.3.4

    Mettez à jour vers 3.3.4

  • mariadb npm

    Plages de versions concernées
    • SEMVER: ≥ 3.4.0, < 3.4.6

    Mettez à jour vers 3.4.6

  • mariadb npm

    Plages de versions concernées
    • SEMVER: ≥ 3.5.0, < 3.5.3

    Mettez à jour vers 3.5.3

Sources originales

Vérifiez votre serveur →