CVE-2026-56356
CVE-2026-56356 · n8n - Stored Cross-Site Scripting in Chat Trigger Node Custom CSS Field
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
n8n contains a stored cross-site scripting vulnerability in the Chat Trigger node's Custom CSS field due to a misconfiguration of the sanitize-html library. Affected releases are those before 1.123.27, the 2.0.0 through 2.13.2 line, and 2.14.0 (fixed in 1.123.27, 2.13.3, and 2.14.1). An authenticated user with permission to create or modify workflows can inject JavaScript that bypasses sanitization, resulting in stored XSS against any user who visits the public chat page.
CVSS 5.1 · Moyenne · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
n8n
- Versions du logiciel
- ≥ 0, < 1.123.27: Concernée (semver)
- 1.123.27: Non concernée (semver)
- ≥ 2.0.0-rc.0, < 2.13.3: Concernée (semver)
- 2.13.3: Non concernée (semver)
- ≥ 2.14.0, < 2.14.1: Concernée (semver)
- 2.14.1: Non concernée (semver)
Mettez à jour vers 1.123.27; Mettez à jour vers 2.13.3; Mettez à jour vers 2.14.1
n8n
- Versions du logiciel
- ≥ 0, < 2.14.1: Concernée (semver)
- 2.14.1: Non concernée (semver)
Mettez à jour vers 2.14.1
n8n
- Versions du logiciel
- ≥ 0, < 2.13.3: Concernée (semver)
- 2.13.3: Non concernée (semver)
Mettez à jour vers 2.13.3
n8n npm
- Plages de versions concernées
- SEMVER: < 1.123.27
Mettez à jour vers 1.123.27
n8n npm
- Versions du logiciel
- 2.14.0
- Plages de versions concernées
- SEMVER: ≥ 2.14.0, < 2.14.1
Mettez à jour vers 2.14.1
n8n npm
- Plages de versions concernées
- SEMVER: ≥ 2.0.0-rc.0, < 2.13.3
Mettez à jour vers 2.13.3