CVE-2026-59869
CVE-2026-59869 · js-yaml: YAML merge-key chains can force quadratic CPU consumption
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
js-yaml is a JavaScript YAML parser and dumper. From 3.0.0 before 3.15.0 and from 4.0.0 before 4.3.0, js-yaml can spend quadratic CPU time parsing a document whose size grows only linearly when a chain of mappings uses merge keys where each mapping merges the previous one. This issue is fixed in versions 3.15.0 and 4.3.0.
CVSS 7.5 · Élevée · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
js-yaml
- Versions du logiciel
- >= 3.0.0, < 3.15.0: Concernée
- >= 4.0.0, < 4.3.0: Concernée
Aucun correctif publié
node-js-yaml Debian:12
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Debian:13
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Debian:14
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- Plages de versions concernées
- ECOSYSTEM: < 4.2.0+~4.0.9-2
Mettez à jour vers 4.2.0+~4.0.9-2
js-yaml npm
- Plages de versions concernées
- SEMVER: ≥ 3.0.0, < 3.15.0
Mettez à jour vers 3.15.0
js-yaml npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.0, < 4.3.0
Mettez à jour vers 4.3.0
node-js-yaml Ubuntu:18.04:LTS
- Versions du logiciel
- 3.9.1+dfsg-1
- 3.10.0+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:20.04:LTS
- Versions du logiciel
- 3.13.1+dfsg-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:22.04:LTS
- Versions du logiciel
- 3.14.1+dfsg+~3.12.6-2
- 4.1.0+dfsg+~4.0.5-4ubuntu1
- 4.1.0+dfsg+~4.0.5-5
- 4.1.0+dfsg+~4.0.5-6
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:24.04:LTS
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:25.10
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:26.10
- Versions du logiciel
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:26.04:LTS
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/nodeca/js-yaml/security/advisories/GHSA-52cp-r559-cp3m
- https://github.com/nodeca/js-yaml/commit/24f13e79ee1343a7e30bd6f6c9d9cdbf0ac9b2b7
- https://github.com/nodeca/js-yaml/commit/59423c6f8cdc78742ac00e25a4dd39ef16b702e4
- https://github.com/nodeca/js-yaml/releases/tag/3.15.0
- https://github.com/nodeca/js-yaml/releases/tag/4.3.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-59869