CVE-2026-62992
CVE-2026-62992 · Smarty: Symlink path traversal out of trusted directories
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to 5.8.2 (and 4.5.7 on the 4.x line), Security::_checkDir() does not fully resolve symbolic links before validating that a requested path lies within a configured secure directory. An attacker able to place or reference a symlink within a directory Smarty treats as trusted (e.g., a template or config directory) could use it to point outside the intended secure directory, bypassing the containment check and reading arbitrary files accessible to the PHP process. This issue is fixed in versions 5.8.2 and 4.5.7.
CVSS 6.9 · Moyenne · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Produits et versions concernés
smarty
- Versions du logiciel
- >= 5.0.0, < 5.8.2: Concernée
- < 4.5.7: Concernée
Aucun correctif publié
smarty3 Debian:12
- Versions du logiciel
- 3.1.47-2
- 3.1.47-2+deb12u1
- 3.1.48-1
- 3.1.48-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty3 Debian:13
- Versions du logiciel
- 3.1.48-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty3 Debian:14
- Versions du logiciel
- 3.1.48-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty4 Debian:12
- Versions du logiciel
- 4.3.0-1
- 4.3.0-1+deb12u1
- 4.3.0-1+deb12u2
- 4.3.1-1
- 4.5.4-1
- 4.5.5-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty4 Debian:13
- Versions du logiciel
- 4.5.5-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty4 Debian:14
- Versions du logiciel
- 4.5.5-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty/smarty Packagist
- Versions du logiciel
- v5.0.0
- v5.0.1
- v5.0.2
- v5.1.0
- v5.2.0
- v5.3.0
- v5.3.1
- v5.4.0
- v5.4.1
- v5.4.2
- v5.4.3
- v5.4.4
- v5.4.5
- v5.5.0
- v5.5.1
- v5.5.2
- v5.6.0
- v5.7.0
- v5.8.0
- v5.8.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 5.0.0, < 5.8.2
Mettez à jour vers 5.8.2
smarty/smarty Packagist
- Versions du logiciel
- v2.6.24
- v2.6.25
- v2.6.26
- v2.6.27
- v2.6.28
- v2.6.29
- v2.6.30
- v2.6.31
- v2.6.33
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.18
- v3.1.19
- v3.1.20
- v3.1.21
- v3.1.23
- v3.1.24
- v3.1.25
- v3.1.26
- v3.1.27
- v3.1.28
- v3.1.29
- v3.1.30
- v3.1.31
- v3.1.32
- v3.1.33
- v3.1.34
- v3.1.35
- v3.1.36
- v3.1.37
- v3.1.37.1
- v3.1.38
- v3.1.39
- v3.1.40
- v3.1.41
- v3.1.42
- v3.1.43
- v3.1.44
- v3.1.45
- v3.1.46
- v3.1.47
- v3.1.48
- v4.0.0
- v4.0.0-rc.0
- v4.0.1
- v4.0.2
- v4.0.3
- v4.0.4
- v4.1.0
- v4.1.1
- v4.2.0
- v4.2.1
- v4.3.0
- v4.3.1
- v4.3.2
- v4.3.3
- v4.3.4
- v4.3.5
- v4.4.0
- v4.4.1
- v4.5.0
- v4.5.1
- v4.5.2
- v4.5.3
- v4.5.4
- v4.5.5
- v4.5.6
- Plages de versions concernées
- ECOSYSTEM: < 4.5.7
Mettez à jour vers 4.5.7
smarty3 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 3.1.21-1
- 3.1.21-1ubuntu1
- 3.1.21-1ubuntu1+esm1
- 3.1.21-1ubuntu1+esm2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty3 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 3.1.31+20161214.1.c7d42e4+selfpack1-2
- 3.1.31+20161214.1.c7d42e4+selfpack1-3
- 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
- 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty3 Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 3.1.33+20180830.1.3a78a21f+selfpack1-1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty3 Ubuntu:22.04:LTS
- Versions du logiciel
- 3.1.39-2
- 3.1.39-2ubuntu1
- 3.1.39-2ubuntu1.22.04.1
- 3.1.39-2ubuntu1.22.04.2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty3 Ubuntu:24.04:LTS
- Versions du logiciel
- 3.1.48-1
- 3.1.48-1ubuntu0.24.04.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty4 Ubuntu:24.04:LTS
- Versions du logiciel
- 4.3.1-1
- 4.3.1-1ubuntu0.24.04.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty3 Ubuntu:26.10
- Versions du logiciel
- 3.1.48-2build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty4 Ubuntu:26.10
- Versions du logiciel
- 4.5.5-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty3 Ubuntu:26.04:LTS
- Versions du logiciel
- 3.1.48-2
- 3.1.48-2build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
smarty4 Ubuntu:26.04:LTS
- Versions du logiciel
- 4.5.5-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/smarty-php/smarty/security/advisories/GHSA-f6wf-28g6-769x
- https://github.com/smarty-php/smarty/commit/99c048ce7a590c519b79fbd38ad0143a08183a1f
- https://github.com/smarty-php/smarty/commit/a1ccdb0518021a559b4066c37b76a42c86bbce90
- https://github.com/smarty-php/smarty/releases/tag/v4.5.7
- https://github.com/smarty-php/smarty/releases/tag/v5.8.2
- https://nvd.nist.gov/vuln/detail/CVE-2026-62992