CVE-2026-66079
CVE-2026-66079 · RabbitMQ: Pre-auth AMQP 1.0 array32 zero-width element DoS
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6, parse_array_primitive/2 for constructor 0x45 (list0) returns an element with byte-width B = 0. The enclosing array32 parser at line 148 reads a 4-byte Count from the wire and loops Count times consuming B bytes each , with B = 0, no input is consumed and the loop builds a list of Count empty elements bounded only by the 32-bit field. The SASL-mechanisms / SASL-init frame is parsed by amqp10_framing:decode_bin/1 from rabbit_amqp_reader.erl:412 before authentication completes. The pre-auth incoming_max_frame_size (default 8192 bytes) caps the frame, not the Count field, so a 19-byte payload with Count = 0xFFFFFFFF is accepted. No max_heap_size is set on the reader process. An unauthenticated network attacker can crash any RabbitMQ node that has the AMQP 1.0 listener enabled (default port 5672) by sending a single ~19-byte frame. The reader process attempts to build a list of ~4 billion empty elements, exhausting heap memory and terminating the Erlang VM. All tenants and protocols on the node lose service. Preconditions include Network reachability to the AMQP listener (port 5672, enabled by default) No authentication required. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.
CVSS 8.2 · Élevée · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · database
Produits et versions concernés
rabbitmq
- Versions du logiciel
- >= 3.13.0, < 3.13.15: Concernée
- >= 4.0.0, < 4.0.20: Concernée
- >= 4.1.0, < 4.1.11: Concernée
- >= 4.2.0, < 4.2.6: Concernée
Aucun correctif publié
rabbitmq-server Debian:12
- Versions du logiciel
- 3.10.8-1.1
- 3.10.8-1.1+deb12u1
- 3.10.8-2
- 3.10.8-3
- 3.10.8-4
- 3.12.1-1
- 3.12.1-1.1
- 4.0.5-1
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-2
- 4.0.5-3
- 4.0.5-4
- 4.0.5-5
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- 4.3.6-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rabbitmq-server Debian:13
- Versions du logiciel
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-6+deb13u1
- 4.0.5-6+deb13u2
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- 4.3.6-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rabbitmq-server Debian:14
- Versions du logiciel
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- Plages de versions concernées
- ECOSYSTEM: < 4.3.0-2
Mettez à jour vers 4.3.0-2
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- 3.5.7-1ubuntu0.16.04.4+esm1
- 3.5.7-1ubuntu0.16.04.4+esm2
- Plages de versions concernées
- ECOSYSTEM: < 3.5.7-1ubuntu0.16.04.4+esm3
Mettez à jour vers 3.5.7-1ubuntu0.16.04.4+esm3
rabbitmq-server Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- 3.6.10-1ubuntu0.5
- Plages de versions concernées
- ECOSYSTEM: < 3.6.10-1ubuntu0.5+esm1
Mettez à jour vers 3.6.10-1ubuntu0.5+esm1
rabbitmq-server Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- 3.8.3-0ubuntu0.2
- 3.8.3-0ubuntu0.3
- 3.8.3-0ubuntu0.3+esm1
- Plages de versions concernées
- ECOSYSTEM: < 3.8.3-0ubuntu0.3+esm2
Mettez à jour vers 3.8.3-0ubuntu0.3+esm2
rabbitmq-server Ubuntu:22.04:LTS
- Versions du logiciel
- 3.8.9-3ubuntu1
- 3.9.8-1
- 3.9.8-2
- 3.9.8-3
- 3.9.8-5
- 3.9.8-6
- 3.9.13-1
- 3.9.13-1ubuntu0.22.04.1
- 3.9.13-1ubuntu0.22.04.2
- 3.9.27-0ubuntu0.1
- 3.9.27-0ubuntu0.2
- 3.9.27-0ubuntu0.5
- Plages de versions concernées
- ECOSYSTEM: < 3.9.27-0ubuntu0.6
Mettez à jour vers 3.9.27-0ubuntu0.6
rabbitmq-server Ubuntu:24.04:LTS
- Versions du logiciel
- 3.12.1-1
- 3.12.1-1ubuntu1
- 3.12.1-1ubuntu1.2
- 3.12.1-1ubuntu1.4
- 3.12.1-1ubuntu1.6
- Plages de versions concernées
- ECOSYSTEM: < 3.12.1-1ubuntu1.7
Mettez à jour vers 3.12.1-1ubuntu1.7
rabbitmq-server Ubuntu:26.04:LTS
- Versions du logiciel
- 4.0.5-8ubuntu2
- 4.0.5-10ubuntu1
- 4.0.5-10ubuntu2
- 4.0.5-10ubuntu3
- 4.0.5-10ubuntu4
- 4.0.5-10ubuntu5
- 4.0.5-10ubuntu5.1
- Plages de versions concernées
- ECOSYSTEM: < 4.0.5-10ubuntu5.2
Mettez à jour vers 4.0.5-10ubuntu5.2