p PatchFirst

CVE-2026-67237

CVE-2026-67237 · RabbitMQ: Reflected XSS via the OAuth bootstrap JS endpoint

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.8 and 4.3.2, set_token_auth/2 inserted a bearer token from the Authorization header or access_token cookie into OAuth bootstrap JavaScript without escaping, allowing attacker-controlled token content to execute JavaScript in the management UI origin. The endpoint is exposed before authentication only when management.oauth_enabled is true, and exploitation through the cookie path additionally requires the attacker to plant an access_token cookie on the management host. This issue is fixed in versions 4.2.8 and 4.3.2.

CVSS 7.5 · Élevée · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · database

Produits et versions concernés

  • rabbitmq

    Versions du logiciel
    • >= 4.2.0, < 4.2.8: Concernée
    • >= 4.3.0, < 4.3.2: Concernée

    Aucun correctif publié

  • rabbitmq-server Debian:14

    Versions du logiciel
    • 4.0.5-10
    • 4.0.5-11
    • 4.0.5-12
    • 4.0.5-13
    • 4.0.5-14
    • 4.0.5-6
    • 4.0.5-8
    • 4.0.5-9
    • 4.3.0-1
    • 4.3.0-2
    • 4.3.0-3
    Plages de versions concernées
    • ECOSYSTEM: < 4.3.2-1

    Mettez à jour vers 4.3.2-1

  • rabbitmq-server Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 3.5.4-1
    • 3.5.4-3
    • 3.5.4-3.1
    • 3.5.7-1
    • 3.5.7-1ubuntu0.16.04.1
    • 3.5.7-1ubuntu0.16.04.2
    • 3.5.7-1ubuntu0.16.04.4
    • 3.5.7-1ubuntu0.16.04.4+esm1
    • 3.5.7-1ubuntu0.16.04.4+esm2
    Plages de versions concernées
    • ECOSYSTEM: < 3.5.7-1ubuntu0.16.04.4+esm3

    Mettez à jour vers 3.5.7-1ubuntu0.16.04.4+esm3

  • rabbitmq-server Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 3.6.10-1
    • 3.6.10-1ubuntu0.1
    • 3.6.10-1ubuntu0.3
    • 3.6.10-1ubuntu0.4
    • 3.6.10-1ubuntu0.5
    Plages de versions concernées
    • ECOSYSTEM: < 3.6.10-1ubuntu0.5+esm1

    Mettez à jour vers 3.6.10-1ubuntu0.5+esm1

  • rabbitmq-server Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 3.7.8-4ubuntu2
    • 3.7.18-1
    • 3.8.2-0ubuntu1
    • 3.8.2-0ubuntu1.1
    • 3.8.2-0ubuntu1.2
    • 3.8.2-0ubuntu1.3
    • 3.8.2-0ubuntu1.4
    • 3.8.2-0ubuntu1.5
    • 3.8.3-0ubuntu0.1
    • 3.8.3-0ubuntu0.2
    • 3.8.3-0ubuntu0.3
    • 3.8.3-0ubuntu0.3+esm1
    Plages de versions concernées
    • ECOSYSTEM: < 3.8.3-0ubuntu0.3+esm2

    Mettez à jour vers 3.8.3-0ubuntu0.3+esm2

  • rabbitmq-server Ubuntu:22.04:LTS

    Versions du logiciel
    • 3.8.9-3ubuntu1
    • 3.9.8-1
    • 3.9.8-2
    • 3.9.8-3
    • 3.9.8-5
    • 3.9.8-6
    • 3.9.13-1
    • 3.9.13-1ubuntu0.22.04.1
    • 3.9.13-1ubuntu0.22.04.2
    • 3.9.27-0ubuntu0.1
    • 3.9.27-0ubuntu0.2
    • 3.9.27-0ubuntu0.5
    Plages de versions concernées
    • ECOSYSTEM: < 3.9.27-0ubuntu0.6

    Mettez à jour vers 3.9.27-0ubuntu0.6

  • rabbitmq-server Ubuntu:24.04:LTS

    Versions du logiciel
    • 3.12.1-1
    • 3.12.1-1ubuntu1
    • 3.12.1-1ubuntu1.2
    • 3.12.1-1ubuntu1.4
    • 3.12.1-1ubuntu1.6
    Plages de versions concernées
    • ECOSYSTEM: < 3.12.1-1ubuntu1.7

    Mettez à jour vers 3.12.1-1ubuntu1.7

  • rabbitmq-server Ubuntu:26.04:LTS

    Versions du logiciel
    • 4.0.5-8ubuntu2
    • 4.0.5-10ubuntu1
    • 4.0.5-10ubuntu2
    • 4.0.5-10ubuntu3
    • 4.0.5-10ubuntu4
    • 4.0.5-10ubuntu5
    • 4.0.5-10ubuntu5.1
    Plages de versions concernées
    • ECOSYSTEM: < 4.0.5-10ubuntu5.2

    Mettez à jour vers 4.0.5-10ubuntu5.2

Sources originales

Vérifiez votre serveur →