CVE-2026-69149
CVE-2026-69149 · Angular SSR: Missing Fallback Raw-Content Serialization Escaping leads to Cross-Site Scripting (XSS)
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.7, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of fallback raw-content elements (<iframe>, <noembed>, <noframes>, and <noscript>). This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.7.
CVSS 8.6 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
angular
- Versions du logiciel
- < 20.3.27: Concernée
- >= 21.0.0-next.0, < 21.2.19: Concernée
- >= 22.0.0-next.0, < 22.0.7: Concernée
Aucun correctif publié
platform-server
- Versions du logiciel
- < 20.3.27: Concernée
- >= 21.0.0-next.0, < 21.2.19: Concernée
- >= 22.0.0-next.0, < 22.0.7: Concernée
Aucun correctif publié
angular.js Debian:12
- Versions du logiciel
- 1.8.3-1
- 1.8.3-1+deb12u1
- 1.8.3-1+deb12u1~deb11u1
- 1.8.3-2
- 1.8.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Debian:13
- Versions du logiciel
- 1.8.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
@angular/platform-server npm
- Plages de versions concernées
- SEMVER: ≥ 22.0.0-next.0, < 22.0.7
Mettez à jour vers 22.0.7
@angular/platform-server npm
- Plages de versions concernées
- SEMVER: ≥ 21.0.0-next.0, < 21.2.19
Mettez à jour vers 21.2.19
@angular/platform-server npm
- Plages de versions concernées
- SEMVER: ≥ 20.0.0-next.0, < 20.3.27
Mettez à jour vers 20.3.27
@angular/platform-server npm
- Plages de versions concernées
- SEMVER: ≤ 19.2.25
Aucun correctif publié
angular.js Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:22.04:LTS
- Versions du logiciel
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:24.04:LTS
- Versions du logiciel
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:26.10
- Versions du logiciel
- 1.8.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:26.04:LTS
- Versions du logiciel
- 1.8.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/angular/angular/security/advisories/GHSA-vpx6-8pjr-4g3v
- https://github.com/angular/angular/pull/69675
- https://github.com/angular/angular/pull/69714
- https://github.com/angular/angular/pull/69929
- https://github.com/angular/angular/pull/69930
- https://github.com/angular/domino/pull/32
- https://github.com/angular/domino/commit/f88e5aa49cf2804d7c2df22ef1640eb4ec43dd56
- https://nvd.nist.gov/vuln/detail/CVE-2026-69149