p PatchFirst

CVE-2026-69151

CVE-2026-69151 · Angular i18n: Cross-Site Scripting (XSS) via event-handler attributes

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.1, the Angular compiler i18n pipeline permits i18n-onerror and other i18n-on event-handler attributes, allowing a lower-trust translation file to replace a static handler with executable JavaScript. This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.1.

CVSS 7.6 · Élevée · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • angular

    Versions du logiciel
    • >= 22.0.0-next.0, < 22.0.1: Concernée
    • >= 21.0.0-next.0, < 21.2.19: Concernée
    • < 20.3.27: Concernée

    Aucun correctif publié

  • compiler

    Versions du logiciel
    • >= 22.0.0-next.0, < 22.0.1: Concernée
    • >= 21.0.0-next.0, < 21.2.19: Concernée
    • < 20.3.27: Concernée

    Aucun correctif publié

  • core

    Versions du logiciel
    • >= 22.0.0-next.0, < 22.0.1: Concernée
    • >= 21.0.0-next.0, < 21.2.19: Concernée
    • < 20.3.27: Concernée

    Aucun correctif publié

  • angular.js Debian:12

    Versions du logiciel
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Debian:13

    Versions du logiciel
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • @angular/compiler npm

    Plages de versions concernées
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.1

    Mettez à jour vers 22.0.1

  • @angular/compiler npm

    Plages de versions concernées
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.19

    Mettez à jour vers 21.2.19

  • @angular/compiler npm

    Plages de versions concernées
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.27

    Mettez à jour vers 20.3.27

  • @angular/compiler npm

    Plages de versions concernées
    • SEMVER: ≤ 19.2.25

    Aucun correctif publié

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.1

    Mettez à jour vers 22.0.1

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.19

    Mettez à jour vers 21.2.19

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.27

    Mettez à jour vers 20.3.27

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≤ 19.2.25

    Aucun correctif publié

  • angular.js Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 1.2.28-1ubuntu2
    • 1.2.28-1ubuntu2+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 1.5.10-1
    • 1.5.10-1ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 1.5.10-1
    • 1.7.9-1
    • 1.7.9-1ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.8.2-2
    • 1.8.2-2ubuntu0.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:24.04:LTS

    Versions du logiciel
    • 1.8.3-1
    • 1.8.3-1ubuntu0.24.04.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:26.10

    Versions du logiciel
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:26.04:LTS

    Versions du logiciel
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →