p PatchFirst

CVE-2026-73420

CVE-2026-73420 · NextAuth.js: Email normalizer validates the address before Unicode normalization, allowing a homoglyph @ bypass

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

NextAuth.js provides authentication for Next.js. Prior to @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32, the defaultNormalizer used by the email and magic-link sign-in flow validates an address before applying Unicode normalization. An address can contain a Unicode character such as U+FF20 FULLWIDTH COMMERCIAL AT that is not ASCII at-sign but canonicalizes to an ASCII at-sign under NFKC or NFKD normalization. The address passes the normalizer's single-at-sign check, but a downstream sendVerificationRequest mail library or delivery service that normalizes the address can then see two at-sign separators and deliver the passwordless sign-in link to an attacker-controlled recipient. Applications are affected when the email provider uses the built-in normalizer rather than a custom normalizeIdentifier and the downstream sender applies Unicode normalization. An attacker who knows a victim's email address can request the misrouted magic link and sign in as the victim without victim interaction. This issue is fixed in @auth/core 0.41.3 and next-auth 4.24.15 and 5.0.0-beta.32.

CVSS 9.1 · Critique · EPSS 0,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • next-auth

    Versions du logiciel
    • < 4.24.15: Concernée
    • >= 5.0.0-beta.4, < 5.0.0-beta.32: Concernée

    Aucun correctif publié

  • core

    Versions du logiciel
    • >= 0.1.0, < 0.41.3: Concernée

    Aucun correctif publié

  • @auth/core npm

    Plages de versions concernées
    • SEMVER: ≥ 0.1.0, < 0.41.3

    Mettez à jour vers 0.41.3

  • next-auth npm

    Plages de versions concernées
    • SEMVER: ≥ 4.10.3, < 4.24.15

    Mettez à jour vers 4.24.15

  • next-auth npm

    Plages de versions concernées
    • SEMVER: ≥ 5.0.0-beta.1, < 5.0.0-beta.32

    Mettez à jour vers 5.0.0-beta.32

Sources originales

Vérifiez votre serveur →