p PatchFirst

CVE-2026-76172

CVE-2026-76172 · fast-uri vulnerable to host confusion via percent-encoded scheme normalization

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

fast-uri is a URI parser for Node.js. During parsing it runs a legacy decoding pass over the scheme component and never re-escapes the result, and serialization writes the scheme back out verbatim, unlike the host component which is re-escaped. As a result an input whose scheme carries percent-encoded slashes parses as a scheme with no authority, so the parsed host and error are both undefined, yet resolving or normalizing that same input emits a network-path reference whose authority is attacker-chosen and re-parses to that host. An application that allowlists on the parsed host, or treats a reference with no authority as safe to resolve against its base, gets the opposite of what it checked, giving an off-site redirect, server-side request forgery, or address-policy bypass. The legacy decoder also expands non-standard escape forms, widening the issue past upstream filters, and control characters in the scheme can reach the output as raw carriage return and line feed. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which reject a scheme that is not valid after decoding. Users should upgrade to a patched version.

CVSS 7.5 · Élevée · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • fast-uri

    Versions du logiciel
    • ≥ 2.3.1, < 2.4.5: Concernée (semver)
    • 2.4.5: Non concernée (semver)
    • ≥ 3.0.0, < 3.1.6: Concernée (semver)
    • 3.1.6: Non concernée (semver)
    • ≥ 4.0.0, < 4.1.3: Concernée (semver)
    • 4.1.3: Non concernée (semver)

    Mettez à jour vers 2.4.5; Mettez à jour vers 3.1.6; Mettez à jour vers 4.1.3

  • node-ajv Debian:13

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Debian:14

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    Plages de versions concernées
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.4-1

    Mettez à jour vers 8.20.0~ds+~cs7.1.4-1

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 2.3.1, < 2.4.5

    Mettez à jour vers 2.4.5

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 3.0.0, < 3.1.6

    Mettez à jour vers 3.1.6

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 4.0.0, < 4.1.3

    Mettez à jour vers 4.1.3

  • node-ajv Ubuntu:18.04:LTS

    Versions du logiciel
    • 5.0.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:20.04:LTS

    Versions du logiciel
    • 6.10.2-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:22.04:LTS

    Versions du logiciel
    • 6.12.6-2
    • 6.12.6-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:24.04:LTS

    Versions du logiciel
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:26.10

    Versions du logiciel
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:26.04:LTS

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →