p PatchFirst

CVE-2026-84890

CVE-2026-84890 · undici vulnerable to Denial of Service via unbounded decompression of compressed responses

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

CVSS 5.9 · Moyenne · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • undici

    Versions du logiciel
    • ≥ 7.15.0, < 7.29.1: Concernée (semver)
    • 7.29.1: Non concernée (semver)
    • ≥ 8.0.0, < 8.10.2: Concernée (semver)
    • 8.10.2: Non concernée (semver)

    Mettez à jour vers 7.29.1; Mettez à jour vers 8.10.2

  • node-undici Debian:12

    Versions du logiciel
    • 5.15.0+dfsg1+~cs20.10.9.3-1
    • 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u1
    • 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u2
    • 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3
    • 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4
    • 5.19.1+dfsg1+~cs20.10.9.5-1
    • 5.19.1+dfsg1+~cs20.10.9.5-2
    • 5.22.1+dfsg1+~cs20.10.10.2-1
    • 5.26.3+dfsg1+~cs23.10.12-1
    • 5.26.3+dfsg1+~cs23.10.12-2
    • 5.26.3+dfsg1+~cs23.10.12-3
    • 5.28.0+dfsg1+~cs23.11.12.3-1
    • 5.28.0+dfsg1+~cs23.11.12.3-2
    • 5.28.2+dfsg1+~cs23.11.12.3-1
    • 5.28.2+dfsg1+~cs23.11.12.3-2
    • 5.28.2+dfsg1+~cs23.11.12.3-3
    • 5.28.2+dfsg1+~cs23.11.12.3-4
    • 5.28.2+dfsg1+~cs23.11.12.3-5
    • 5.28.2+dfsg1+~cs23.11.12.3-6
    • 5.28.4+dfsg1+~cs23.12.11-1
    • 5.28.4+dfsg1+~cs23.12.11-2
    • 7.1.0+dfsg1+~cs24.12.10-1
    • 7.15.0+dfsg+~cs3.2.0-1
    • 7.15.0+dfsg+~cs3.2.0-3
    • 7.16.0+dfsg+~cs3.2.0-1
    • 7.16.0+dfsg+~cs3.2.0-2
    • 7.18.2+dfsg+~cs3.2.0-1
    • 7.2.3+dfsg1+~cs24.12.11-1
    • 7.2.3+dfsg1+~cs24.12.11-2
    • 7.24.5+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-2
    • 7.24.6+dfsg+~cs3.2.0-3
    • 7.3.0+dfsg1+~cs24.12.11-1
    • 7.3.0+dfsg1+~cs24.12.11-2
    • 8.10.2+dfsg+~cs3.2.2-1
    • 8.5.0+dfsg+~cs3.2.0-1
    • 8.5.0+dfsg+~cs3.2.0-2
    • 8.5.0+dfsg+~cs3.2.0-3
    • 8.9.0+dfsg+~cs3.2.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-undici Debian:13

    Versions du logiciel
    • 7.15.0+dfsg+~cs3.2.0-1
    • 7.15.0+dfsg+~cs3.2.0-3
    • 7.16.0+dfsg+~cs3.2.0-1
    • 7.16.0+dfsg+~cs3.2.0-2
    • 7.18.2+dfsg+~cs3.2.0-1
    • 7.24.5+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-2
    • 7.24.6+dfsg+~cs3.2.0-3
    • 7.3.0+dfsg1+~cs24.12.11-1
    • 7.3.0+dfsg1+~cs24.12.11-2
    • 8.10.2+dfsg+~cs3.2.2-1
    • 8.5.0+dfsg+~cs3.2.0-1
    • 8.5.0+dfsg+~cs3.2.0-2
    • 8.5.0+dfsg+~cs3.2.0-3
    • 8.9.0+dfsg+~cs3.2.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-undici Debian:14

    Versions du logiciel
    • 7.15.0+dfsg+~cs3.2.0-1
    • 7.15.0+dfsg+~cs3.2.0-3
    • 7.16.0+dfsg+~cs3.2.0-1
    • 7.16.0+dfsg+~cs3.2.0-2
    • 7.18.2+dfsg+~cs3.2.0-1
    • 7.24.5+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-2
    • 7.24.6+dfsg+~cs3.2.0-3
    • 7.3.0+dfsg1+~cs24.12.11-1
    • 7.3.0+dfsg1+~cs24.12.11-2
    • 8.5.0+dfsg+~cs3.2.0-1
    • 8.5.0+dfsg+~cs3.2.0-2
    • 8.5.0+dfsg+~cs3.2.0-3
    • 8.9.0+dfsg+~cs3.2.0-1
    Plages de versions concernées
    • ECOSYSTEM: < 8.10.2+dfsg+~cs3.2.2-1

    Mettez à jour vers 8.10.2+dfsg+~cs3.2.2-1

  • undici npm

    Plages de versions concernées
    • SEMVER: ≥ 7.15.0, < 7.29.1

    Mettez à jour vers 7.29.1

  • undici npm

    Plages de versions concernées
    • SEMVER: ≥ 8.0.0, < 8.10.2

    Mettez à jour vers 8.10.2

  • node-undici Ubuntu:24.04:LTS

    Versions du logiciel
    • 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1
    • 5.26.3+dfsg1+~cs23.10.12-2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-undici Ubuntu:26.10

    Versions du logiciel
    • 7.18.2+dfsg+~cs3.2.0-1build1
    • 7.24.6+dfsg+~cs3.2.0-3
    • 8.5.0+dfsg+~cs3.2.0-2
    • 8.5.0+dfsg+~cs3.2.0-3
    • 8.9.0+dfsg+~cs3.2.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-undici Ubuntu:26.04:LTS

    Versions du logiciel
    • 7.3.0+dfsg1+~cs24.12.11-2
    • 7.16.0+dfsg+~cs3.2.0-2
    • 7.18.2+dfsg+~cs3.2.0-1
    • 7.18.2+dfsg+~cs3.2.0-1build1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →