CVE-2026-87107
CVE-2026-87107 · Consul vulnerable to an authorization bypass in the catalog deregistration path
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Consul and Consul Enterprise are vulnerable to an authorization bypass in the catalog deregistration path that may allow a local ACL token to delete peer-imported catalog objects. A caller with {{service:write}} or {{node:write}} permission may exploit this issue to remove services, checks, or nodes imported from a peered cluster without holding authority over the peer origin. This vulnerability (CVE-2026-87107) is fixed in Consul 2.0.4 and Consul Enterprise 1.21.18, 1.22.12 and 2.0.4.
CVSS 5.4 · Moyenne · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
consul
- Versions du logiciel
- ≥ 1.21.0, < 2.0.4: Concernée (semver)
Mettez à jour vers 2.0.4
consul enterprise
- Versions du logiciel
- ≥ 1.21.0, < 2.0.4: Concernée; ≥ 1.21.18: Non concernée; ≥ 1.22.12: Non concernée (semver)
Mettez à jour vers 1.21.18
consul Ubuntu:18.04:LTS
- Versions du logiciel
- 0.6.4~dfsg-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
consul Ubuntu:20.04:LTS
- Versions du logiciel
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
consul Ubuntu:22.04:LTS
- Versions du logiciel
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié