p PatchFirst

CVE-2026-96883

CVE-2026-96883 · Type confusion in AWS pgcollection allows remote code execution

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions. To remediate this issue, users should upgrade to version 2.1.2 or later.

CVSS 8.7 · Élevée · EPSS 0,7%

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • pgcollection

    Versions du logiciel
    • ≥ 2.0.0, ≤ 2.1.1: Concernée (custom)

    Aucun correctif publié

  • postgresql-9.3 Ubuntu:Pro:14.04:LTS

    Versions du logiciel
    • 9.3.1-1
    • 9.3.2-1
    • 9.3.2-1ubuntu1
    • 9.3.2-1ubuntu2
    • 9.3.3-1
    • 9.3.3-1bzr1
    • 9.3.3-1bzr2
    • 9.3.4-1
    • 9.3.5-0ubuntu0.14.04.1
    • 9.3.6-0ubuntu0.14.04
    • 9.3.7-0ubuntu0.14.04
    • 9.3.8-0ubuntu0.4.04
    • 9.3.9-0ubuntu0.14.04
    • 9.3.10-0ubuntu0.14.04
    • 9.3.11-0ubuntu0.14.04
    • 9.3.12-0ubuntu0.14.04
    • 9.3.13-0ubuntu0.14.04
    • 9.3.14-0ubuntu0.14.04
    • 9.3.15-0ubuntu0.14.04
    • 9.3.16-0ubuntu0.14.04
    • 9.3.17-0ubuntu0.14.04
    • 9.3.18-0ubuntu0.14.04.1
    • 9.3.19-0ubuntu0.14.04
    • 9.3.20-0ubuntu0.14.04
    • 9.3.21-0ubuntu0.14.04
    • 9.3.22-0ubuntu0.14.04
    • 9.3.23-0ubuntu0.14.04
    • 9.3.24-0ubuntu0.14.04
    • 9.3.24-0ubuntu0.14.04+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →