p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de libvirt · Page n° 2

Vulnérabilités publiées pour libvirt au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 86

  1. CVE-2020-10703

    Moyenne · CVSS 6.5EPSS 2,38%Correctif disponible

    CVE-2020-10703

    A NULL pointer dereference was found in the libvirt API responsible introduced in upstream version 3.10.0, and fixed in libvirt 6.0.0, for fetching a storage pool based on its target path. In more detail, this flaw affects storage pools created without a target path such as network-based pools like gluster and RBD. Unprivileged users with a read-only connection could abuse this flaw to crash the libvirt daemon, resulting in a potential denial of service.

    • Mettez à jour vers 6.0.0-2
    Publication Mise à jour
  2. CVE-2020-12430

    Moyenne · CVSS 6.5EPSS 2,27%Correctif disponible

    CVE-2020-12430

    An issue was discovered in qemuDomainGetStatsIOThread in qemu/qemu_driver.c in libvirt 4.10.0 though 6.x before 6.1.0. A memory leak was found in the virDomainListGetStats libvirt API that is responsible for retrieving domain statistics when managing QEMU guests. This flaw allows unprivileged users with a read-only connection to cause a memory leak in the domstats command, resulting in a potential denial of service.

    • Mettez à jour vers 6.4.0-2
    Publication Mise à jour
  3. CVE-2019-10168

    Élevée · CVSS 8.8EPSS 0,55%Correctif disponible

    CVE-2019-10168

    The virConnectBaselineHypervisorCPU() and virConnectCompareHypervisorCPU() libvirt APIs, 4.x.x before 4.10.1 and 5.x.x before 5.4.1, accept an "emulator" argument to specify the program providing emulation for a domain. Since v1.2.19, libvirt will execute that program to probe the domain's capabilities. Read-only clients could specify an arbitrary path for this argument, causing libvirtd to execute a crafted executable with its own privileges.

    • Mettez à jour vers 5.0.0-4
    Publication Mise à jour
  4. CVE-2019-10167

    Élevée · CVSS 8.8EPSS 0,52%Correctif disponible

    CVE-2019-10167

    The virConnectGetDomainCapabilities() libvirt API, versions 4.x.x before 4.10.1 and 5.x.x before 5.4.1, accepts an "emulatorbin" argument to specify the program providing emulation for a domain. Since v1.2.19, libvirt will execute that program to probe the domain's capabilities. Read-only clients could specify an arbitrary path for this argument, causing libvirtd to execute a crafted executable with its own privileges.

    • Mettez à jour vers 5.0.0-4
    Publication Mise à jour
  5. CVE-2019-10166

    Élevée · CVSS 7.8EPSS 0,47%Correctif disponible

    CVE-2019-10166

    It was discovered that libvirtd, versions 4.x.x before 4.10.1 and 5.x.x before 5.4.1, would permit readonly clients to use the virDomainManagedSaveDefineXML() API, which would permit them to modify managed save state files. If a managed save had already been created by a privileged user, a local attacker could modify this file such that libvirtd would execute an arbitrary program when the domain was resumed.

    • Mettez à jour vers 5.0.0-4
    Publication Mise à jour
  6. CVE-2019-10161

    Élevée · CVSS 8.8EPSS 0,52%Correctif disponible

    CVE-2019-10161

    It was discovered that libvirtd before versions 4.10.1 and 5.4.1 would permit read-only clients to use the virDomainSaveImageGetXMLDesc() API, specifying an arbitrary path which would be accessed with the permissions of the libvirtd process. An attacker with access to the libvirtd socket could use this to probe the existence of arbitrary files, cause denial of service or cause libvirtd to execute arbitrary programs.

    • Mettez à jour vers 5.0.0-4
    Publication Mise à jour
  7. CVE-2019-10132

    Élevée · CVSS 8.8EPSS 1,37%Correctif disponible

    CVE-2019-10132

    A vulnerability was found in libvirt >= 4.1.0 in the virtlockd-admin.socket and virtlogd-admin.socket systemd units. A missing SocketMode configuration parameter allows any user on the host to connect using virtlockd-admin-sock or virtlogd-admin-sock and perform administrative tasks against the virtlockd and virtlogd daemons.

    • Mettez à jour vers 5.0.0-3
    Publication Mise à jour
  8. CVE-2019-3886

    Moyenne · CVSS 5.4EPSS 1,12%Correctif disponible

    CVE-2019-3886

    An incorrect permissions check was discovered in libvirt 4.8.0 and above. The readonly permission was allowed to invoke APIs depending on the guest agent, which could lead to potentially disclosing unintended information or denial of service by causing libvirt to block.

    • Mettez à jour vers 5.0.0-2
    Publication Mise à jour
  9. CVE-2011-4600

    Moyenne · CVSS 5.9EPSS 1,78%Correctif disponible

    CVE-2011-4600

    The networkReloadIptablesRules function in network/bridge_driver.c in libvirt before 0.9.9 does not properly handle firewall rules on bridge networks when libvirtd is restarted, which might allow remote attackers to bypass intended access restrictions via a (1) DNS or (2) DHCP query.

    • Mettez à jour vers 0.9.9-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →