p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de phpsysinfo

Vulnérabilités publiées pour phpsysinfo au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 9

  1. CVE-2026-55584

    Élevée · CVSS 7.5EPSS 1,91%Code d’exploitation publicAucun correctif publié

    phpSysInfo: IP allowlist (PSI_ALLOWED) bypass via spoofed X-Forwarded-For / Client-IP headers

    phpSysInfo is a customizable PHP script that displays system information. Prior to 3.4.6, the PSI_ALLOWED access-control check in read_config.php trusts attacker-controlled X-Forwarded-For and Client-IP HTTP headers before REMOTE_ADDR. A remote unauthenticated attacker can supply an allowed address in one of these headers to impersonate a trusted client and access exposed hostname, kernel, CPU, memory, filesystem, and network-interface information. This issue is fixed in version 3.4.6.

    Publication Mise à jour
  2. CVE-2006-3360

    Non évaluéeEPSS 5,57%Correctif disponible

    CVE-2006-3360

    Directory traversal vulnerability in index.php in phpSysInfo 2.5.1 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.

    • Mettez à jour vers 3.2.5-3
    Publication Mise à jour
  3. CVE-2005-3348

    Non évaluéeEPSS 1,98%Correctif disponible

    CVE-2005-3348

    HTTP response splitting vulnerability in index.php in phpSysInfo 2.4 and earlier, as used in phpgroupware 0.9.16 and earlier, and egroupware before 1.0.0.009, allows remote attackers to spoof web content and poison web caches via CRLF sequences in the charset parameter.

    • Mettez à jour vers 2.3-7
    Publication Mise à jour
  4. CVE-2005-3347

    Non évaluéeEPSS 3,55%Correctif disponible

    CVE-2005-3347

    Multiple directory traversal vulnerabilities in index.php in phpSysInfo 2.4 and earlier, as used in phpgroupware 0.9.16 and earlier, and egrouwpware before 1.0.0.009, allow remote attackers to include arbitrary files via .. (dot dot) sequences in the (1) sensor_program parameter or the (2) _SERVER[HTTP_ACCEPT_LANGUAGE] parameter, which overwrites an internal variable, a variant of CVE-2003-0536. NOTE: due to a typo in an advisory, an issue in osh was inadvertently linked to this identifier; the proper identifier for the osh issue is CVE-2005-3346.

    • Mettez à jour vers 2.3-7
    Publication Mise à jour
  5. CVE-2005-0870

    Non évaluéeEPSS 3,72%Code d’exploitation publicCorrectif disponible

    CVE-2005-0870

    Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.

    • Mettez à jour vers 2.3-7
    Publication Mise à jour
  6. CVE-2005-0869

    Non évaluéeEPSS 5,18%Correctif disponible

    CVE-2005-0869

    phpSysInfo 2.3 allows remote attackers to obtain sensitive information via a direct request to (1) class.OpenBSD.inc.php, (2) class.NetBSD.inc.php, (3) class.FreeBSD.inc.php, (4) class.Darwin.inc.php, (5) XPath.class.php, (6) system_header.php, or (7) system_footer.php, which reveal the path in a PHP error message.

    • Mettez à jour vers 2.3-3
    Publication Mise à jour
  7. CVE-2003-0536

    Non évaluéeEPSS 1,47%Code d’exploitation publicCorrectif disponible

    CVE-2003-0536

    Directory traversal vulnerability in phpSysInfo 2.1 and earlier allows attackers with write access to a local directory to read arbitrary files as the PHP user or cause a denial of service via .. (dot dot) sequences in the (1) template or (2) lng parameters.

    • Mettez à jour vers 2.1-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →