p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de dnsjava

Vulnérabilités publiées pour dnsjava au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2023-50868

    Élevée · CVSS 7.5EPSS 74,3%Correctif disponible

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Mettez à jour vers 3.6.2-1
    Publication Mise à jour
  2. CVE-2023-50387

    Élevée · CVSS 7.5EPSS 99,99%Correctif disponible

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Mettez à jour vers 3.6.2-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →