p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de weasyprint

Vulnérabilités publiées pour weasyprint au cours des 30 derniers jours : 1. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 5

  1. CVE-2026-106443

    Élevée · CVSS 8.8EPSS 0,7%Correctif disponible

    WeasyPrint: EPS images reach the Ghostscript interpreter resulting in RCE

    WeasyPrint helps web developers to create PDF documents. Prior to 70.0, the image-loading path in weasyprint/images.py passes fetched image bytes from HTML img URLs, CSS image values, SVG image references, and data URIs to Pillow's generic image dispatcher without excluding EPS or PostScript formats. On hosts with Ghostscript installed, Pillow EpsImagePlugin invokes the interpreter for attacker-controlled PostScript, which can produce interpreter-permitted effects and can lead to remote code execution when the installed Ghostscript version has a usable sandbox bypass. Hosts without Ghostscript do not reach this rasterization path. This issue

    • Mettez à jour vers 70.0-1
    Publication Mise à jour
  2. CVE-2026-55073

    Moyenne · CVSS 6.2EPSS 0,22%Correctif disponible

    WeasyPrint restrictive URL fetcher bypass allows local file read and SSRF

    WeasyPrint helps web developers to create PDF documents. Prior to 70.0, server-side applications that configure a restrictive url_fetcher and pass attacker-influenced values to HTML.write_pdf() can have the restriction bypassed through the xmp_metadata or stylesheets options. In weasyprint/pdf/init.py, xmp_metadata calls select_source() without the document url_fetcher, allowing an accessible local file to be read and embedded verbatim in the output PDF. In weasyprint/document.py, stylesheets constructs CSS() without the document url_fetcher, allowing local or internal resource loading and propagating the permissive fetcher through nested CSS

    • Mettez à jour vers 70.0-1
    Publication Mise à jour
  3. CVE-2026-49452

    Moyenne · CVSS 6.5EPSS 0,37%Correctif disponible

    WeasyPrint: CSS Injection via Presentational Hints

    WeasyPrint helps web developers to create PDF documents. Prior to 69.0, WeasyPrint embeds unescaped HTML presentational-hint attribute values into CSS in weasyprint/css/__init__.py when presentational_hints=True. The background attribute is inserted into a background-image:url() declaration and parsed by tinycss2.parse_blocks_contents(), allowing untrusted HTML to inject additional CSS declarations. Applications that render untrusted HTML with presentational hints enabled can be affected by CSS injection and server-side requests through injected url() values. This issue is fixed in version 69.0.

    • Mettez à jour vers 69.0-1
    Publication Mise à jour
  4. CVE-2025-68616

    Élevée · CVSS 7.5EPSS 0,7%Correctif disponible

    WeasyPrint Vulnerable to Server-Side Request Forgery (SSRF) Protection Bypass via HTTP Redirect

    WeasyPrint helps web developers to create PDF documents. Prior to version 68.0, a server-side request forgery (SSRF) protection bypass exists in WeasyPrint's `default_url_fetcher`. The vulnerability allows attackers to access internal network resources (such as `localhost` services or cloud metadata endpoints) even when a developer has implemented a custom `url_fetcher` to block such access. This occurs because the underlying `urllib` library follows HTTP redirects automatically without re-validating the new destination against the developer's security policy. Version 68.0 contains a patch for the issue.

    • Mettez à jour vers 69.0-1
    Publication Mise à jour
  5. CVE-2024-28184

    Élevée · CVSS 7.4EPSS 0,74%Correctif disponible

    WeasyPrint allows the attachment of arbitrary files and URLs to a PDF

    WeasyPrint helps web developers to create PDF documents. Since version 61.0, there's a vulnerability which allows attaching content of arbitrary files and URLs to a generated PDF document, even if `url_fetcher` is configured to prevent access to files and URLs. This vulnerability has been patched in version 61.2.

    • Mettez à jour vers 61.2-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →