GHSA-4h8f-c635-25p7
GHSA-4h8f-c635-25p7 · ibexa/post-install affected by Breach with Varnish VCL
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
### Impact This is not a vulnerability in the code per se, but included platform.sh Varnish VCL templates and Apache/Nginx vhost templates enable compression of API and JSON messages. This is a potential case of the BREACH vulnerability, which affects HTTP compression, where secrets can be extracted through carefully crafted requests. The fix disables compression in these templates. Please make sure to make the same change in your configuration files, see the release notes for specific instructions. ### Patches - See "Patched versions". - v1.0: https://github.com/ibexa/post-install/commit/d91cc02623dd3263a99a94ace133c95e48909e5d - v4.6: https://github.com/ibexa/post-install/commit/ae7c3c2081a862c75b90828f08bd74436ceb8fe8 ### Workarounds Make sure HTTP compression is disabled for REST API requests and other communication that might contain secrets. ### References - Advisory: https://developers.ibexa.co/security-advisories/ibexa-sa-2024-006-vulnerabilities-in-content-name-pattern-commerce-shop-and-varnish-vhost-templates - Release notes v3.3: https://doc.ibexa.co/en/latest/update_and_migration/from_3.3/update_from_3.3/#v3341 - Release notes v4.6: https://doc.ibexa.co/en/latest/update_and_migration/from_4.6/update_from_4.6/#v4614 - https://github.com/ezsystems/ezplatform-http-cache/security/advisories/GHSA-mgfg-7533-7jf6 - https://github.com/ibexa/http-cache/security/advisories/GHSA-fh7v-q458-7vmw - https://www.breachattack.com/
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
ibexa/post-install Packagist
- Versions du logiciel
- v1.0.0
- v1.0.1
- v1.0.10
- v1.0.11
- v1.0.12
- v1.0.13
- v1.0.14
- v1.0.15
- v1.0.2
- v1.0.3
- v1.0.4
- v1.0.4.1
- v1.0.5
- v1.0.6
- v1.0.7
- v1.0.8
- v1.0.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.0.0, < 1.0.16
Mettez à jour vers 1.0.16
ibexa/post-install Packagist
- Versions du logiciel
- v4.6.0
- v4.6.1
- v4.6.10
- v4.6.11
- v4.6.12
- v4.6.13
- v4.6.2
- v4.6.3
- v4.6.4
- v4.6.5
- v4.6.6
- v4.6.7
- v4.6.8
- v4.6.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 4.6.0, < 4.6.14
Mettez à jour vers 4.6.14
Sources originales
- https://github.com/ezsystems/ezplatform-http-cache/security/advisories/GHSA-mgfg-7533-7jf6
- https://github.com/ibexa/http-cache/security/advisories/GHSA-fh7v-q458-7vmw
- https://github.com/ibexa/post-install/security/advisories/GHSA-4h8f-c635-25p7
- https://github.com/ibexa/post-install/commit/d91cc02623dd3263a99a94ace133c95e48909e5d
- https://developers.ibexa.co/security-advisories/ibexa-sa-2024-006-vulnerabilities-in-content-name-pattern-commerce-shop-and-varnish-vhost-templates
- https://doc.ibexa.co/en/latest/update_and_migration/from_3.3/update_from_3.3/#v3341
- https://doc.ibexa.co/en/latest/update_and_migration/from_4.6/update_from_4.6/#v4614
- https://github.com/ibexa/post-install
- https://www.breachattack.com
- https://osv.dev/vulnerability/GHSA-4h8f-c635-25p7