GHSA-5j8p-438x-rgg5
GHSA-5j8p-438x-rgg5 · SAML PHP Toolkit Vulnerability on xmlseclibs CVE-2025-66475
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
**Summary** There is a critical vulnerability on xmlseclibs [CVE-2025-66475](https://github.com/robrichards/xmlseclibs/security/advisories/GHSA-c4cc-x928-vjw9), a dependency of php-saml Update to the following versions of php-saml which forces the use of patched versions of xmlseclibs: - [2.21.1](https://github.com/SAML-Toolkits/php-saml/releases/tag/2.21.1) - [3.8.1](https://github.com/SAML-Toolkits/php-saml/releases/tag/3.8.1) - [4.3.1](https://github.com/SAML-Toolkits/php-saml/releases/tag/4.3.1) **Impact** Signature Wrapping Vulnerabilities allows an attacker to impersonate a user.
CVSS 9.3 · Critique · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
onelogin/php-saml Packagist
- Versions du logiciel
- 2.0.0
- 2.1.0
- 2.10.0
- 2.10.1
- 2.10.2
- 2.10.3
- 2.10.4
- 2.10.5
- 2.10.6
- 2.10.7
- 2.11.0
- 2.16.0
- 2.17.0
- 2.17.1
- 2.18.0
- 2.18.1
- 2.19.0
- 2.19.1
- 2.20.0
- 2.21.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.6.0
- 2.6.1
- 2.7.0
- 2.8.0
- 2.9.0
- 2.9.1
- v2.12.0
- v2.13.0
- v2.14.0
- v2.15.0
- Plages de versions concernées
- ECOSYSTEM: < 2.21.1
Mettez à jour vers 2.21.1
onelogin/php-saml Packagist
- Versions du logiciel
- 3.1.1
- 3.2.0
- 3.2.1
- 3.3.0
- 3.3.1
- 3.4.0
- 3.4.1
- 3.5.0
- 3.5.1
- 3.6.0
- 3.6.1
- 3.7.0
- 3.8.0
- v3.0.0
- v3.1.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.0.0, < 3.8.1
Mettez à jour vers 3.8.1
onelogin/php-saml Packagist
- Versions du logiciel
- 4.0.0
- 4.0.1
- 4.1.0
- 4.2.0
- 4.3.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 4.0.0, < 4.3.1
Mettez à jour vers 4.3.1
Sources originales
- https://github.com/SAML-Toolkits/php-saml/security/advisories/GHSA-5j8p-438x-rgg5
- https://github.com/robrichards/xmlseclibs/security/advisories/GHSA-c4cc-x928-vjw9
- https://github.com/SAML-Toolkits/php-saml
- https://github.com/SAML-Toolkits/php-saml/releases/tag/2.21.1
- https://github.com/SAML-Toolkits/php-saml/releases/tag/3.8.1
- https://github.com/SAML-Toolkits/php-saml/releases/tag/4.3.1
- https://osv.dev/vulnerability/GHSA-5j8p-438x-rgg5