p PatchFirst

GHSA-5vj8-3v2h-h38v

GHSA-5vj8-3v2h-h38v · Remote Code Execution in next

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Versions of `next` prior to 5.1.0 are vulnerable to Remote Code Execution. The `/path:` route fails to properly sanitize input and passes it to a `require()` call. This allows attackers to execute JavaScript code on the server. Note that prior version 0.9.9 package `next` npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions. ## Recommendation Upgrade to version 5.1.0.

Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 0.9.9, < 5.1.0

    Mettez à jour vers 5.1.0

Sources originales

Vérifiez votre serveur →