GHSA-hjfh-5jmm-xr24
GHSA-hjfh-5jmm-xr24 · laravel-auth0 SDK Does Not Properly Handle File Types in Bulk User Import
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
### Overview In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. ### Am I affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 laravel-auth0 SDK with version between 4.0.0 and 7.18.0, 2. Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0. ### Fix Upgrade Auth0 laravel-auth0 SDK to version 7.19.0 or greater. ### Acknowledgement Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.
CVSS 3.3 · Faible · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
auth0/login Packagist
- Versions du logiciel
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 5.0.0
- 5.0.1
- 5.0.2
- 5.1.0
- 5.2.0
- 5.3.0
- 5.3.1
- 5.4.0
- 6.0.0
- 6.0.1
- 6.1.0
- 6.2.0
- 6.3.0
- 6.4.0
- 6.4.1
- 6.5.0
- 7.0.0
- 7.0.0-BETA1
- 7.0.0-BETA2
- 7.0.1
- 7.1.0
- 7.10.0
- 7.10.1
- 7.11.0
- 7.12.0
- 7.13.0
- 7.14.0
- 7.15.0
- 7.16.0
- 7.17.0
- 7.18.0
- 7.2.0
- 7.2.1
- 7.2.2
- 7.3.0
- 7.4.0
- 7.5.0
- 7.5.1
- 7.5.2
- 7.6.0
- 7.7.0
- 7.8.0
- 7.8.1
- 7.9.0
- 7.9.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 4.0.0, < 7.19.0
Mettez à jour vers 7.19.0
Sources originales
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-hjfh-5jmm-xr24
- https://nvd.nist.gov/vuln/detail/CVE-2025-58769
- https://github.com/auth0/laravel-auth0/commit/c33c609fb041f7fe65deb6133feee0cb33fa80a5
- https://github.com/auth0/laravel-auth0
- https://github.com/auth0/laravel-auth0/releases/tag/7.19.0
- https://osv.dev/vulnerability/GHSA-hjfh-5jmm-xr24