p PatchFirst

GHSA-jmh9-6rjq-gjh9

GHSA-jmh9-6rjq-gjh9 · Vulnerable embedded jQuery Version

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

### Summary PIMCore uses the JavaScript library jQuery in version 3.4.1. This version is vulnerable to cross-site-scripting (XSS). ### Details In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0. Publish Date: 2020-04-29 URL:= https://security.snyk.io/package/npm/jquery/3.4.1

Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • pimcore/admin-ui-classic-bundle Packagist

    Versions du logiciel
    • 1.4.0
    • v1.0.0
    • v1.0.0-BETA1
    • v1.0.0-RC1
    • v1.0.0-RC2
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.0.5
    • v1.0.6
    • v1.1.0
    • v1.1.0-RC1
    • v1.1.1
    • v1.1.2
    • v1.1.3
    • v1.1.4
    • v1.2
    • v1.2.0-RC1
    • v1.2.1
    • v1.2.2
    • v1.2.3
    • v1.3.0
    • v1.3.0-RC1
    • v1.3.1
    • v1.3.2
    • v1.3.3
    • v1.3.4
    • v1.3.5
    • v1.4.1
    • v1.4.2
    Plages de versions concernées
    • ECOSYSTEM: < 1.4.3

    Mettez à jour vers 1.4.3

Sources originales

Vérifiez votre serveur →