p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de @backstage/plugin-catalog-backend

Vulnérabilités publiées pour @backstage/plugin-catalog-backend au cours des 30 derniers jours : 2. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 4

  1. CVE-2026-106498

    Élevée · CVSS 7.7EPSS 0,31%Correctif disponible

    Backstage: Improper URL validation in catalog entity placeholder resolution

    Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.

    • Mettez à jour vers 3.9.1
    Publication Mise à jour
  2. CVE-2026-106496

    Faible · CVSS 3.1EPSS 0,24%Correctif disponible

    Backstage: Inconsistent enforcement of allowed location types during catalog processing

    Backstage is an open framework for building developer portals. Prior to 3.9.1, the @backstage/plugin-catalog-backend package is affected by inconsistent enforcement of allowed location types during catalog processing. Under certain configurations, the catalog backend could process location types that were not intended to be allowed, potentially leading to unintended file access on the backend host. This issue is fixed in version 3.9.1.

    • Mettez à jour vers 3.9.1
    Publication Mise à jour
  3. CVE-2024-45815

    Moyenne · CVSS 6.5EPSS 0,51%Correctif disponible

    Prototype pollution in @backstage/plugin-catalog-backend

    Backstage is an open framework for building developer portals. A malicious actor with authenticated access to a Backstage instance with the catalog backend plugin installed is able to interrupt the service using a specially crafted query to the catalog API. This has been fixed in the `1.26.0` release of the `@backstage/plugin-catalog-backend`. All users are advised to upgrade. There are no known workarounds for this vulnerability.

    • Mettez à jour vers 1.26.0
    Publication Mise à jour
  4. CVE-2023-25571

    Moyenne · CVSS 6.8EPSS 0,45%Correctif disponible

    Backstage has XSS Vulnerability in Software Catalog

    Backstage is an open platform for building developer portals. `@backstage/catalog-model` prior to version 1.2.0, `@backstage/core-components` prior to 0.12.4, and `@backstage/plugin-catalog-backend` prior to 1.7.2 are affected by a cross-site scripting vulnerability. This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack. This vulnerability has been patched in both the frontend and backend implementations. The default `Link` comp

    • Mettez à jour vers 1.7.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →