p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de @deepstream/server

Vulnérabilité publiée pour @deepstream/server au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-63116

    Élevée · CVSS 8.8EPSS 0,51%Correctif disponible

    deepstream: PATCH_MULTI action bypasses Valve permission system allowing unauthorized record writes

    deepstream is a server that allows clients and backend services to sync data, send messages and make rpcs at scale. From 10.1.0 until 10.1.1, src/services/permission/valve/rules-map.ts omits RECORD_ACTION.PATCH_MULTI from RULES_MAP. When an authenticated user sends a PATCH_MULTI record operation while permission.type is config, getRulesForMessage returns a null rule specification and ConfigPermission.canPerformAction treats the missing specification as an unconditional allow instead of applying RULE_TYPES.WRITE. Any authenticated user can therefore modify arbitrary protected records, corrupt application state, or cause service disruption; dep

    • Mettez à jour vers 10.1.1
    Publication Mise à jour
  2. CVE-2026-49252

    Critique · CVSS 9.9EPSS 0,47%Correctif disponible

    deepstream is vulnerable to prototype pollution

    deepstream is a server that allows clients and backend services to sync data, send messages and make rpcs at scale. Versions prior to 10.0.5 are vulnerable to Prototype Pollution. Exploitation can lead to potential privilege escalation from any authenticated user with write permission to any record. This issue has been fixed in version 10.0.5.

    • Mettez à jour vers 10.0.5
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →