p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de @hapi/wreck

Vulnérabilité publiée pour @hapi/wreck au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-48022

    Moyenne · CVSS 6.5EPSS 0,18%Correctif disponible

    @hapi/wreck: Sensitive credential headers leak across cross-port and cross-scheme redirects

    @hapi/wreck is an HTTP client utility. Prior to 18.1.2, Wreck strips credential headers including Authorization, Cookie, and Proxy-Authorization before following a cross-origin redirect, but the origin check compares hostnames only and ignores scheme and port, so credentials are forwarded intact across same-host port changes and HTTPS-to-HTTP downgrades, allowing a co-tenant on an adjacent port or a network-position attacker capable of forging a redirect to capture bearer tokens, session cookies, and proxy credentials and impersonate the victim against the upstream service. This issue is fixed in version 18.1.2.

    • Mettez à jour vers 18.1.2
    Publication Mise à jour
  2. CVE-2026-44979

    Moyenne · CVSS 6.3EPSS 0,42%Correctif disponible

    @hapi/wreck : Sensitive `Proxy-Authorization` header leaked across cross-hostname redirects

    @hapi/wreck is an HTTP client utility. Prior to 18.1.1, when @hapi/wreck follows a 3xx redirect to a different hostname, only the Authorization and Cookie headers are stripped, and the standard credential header Proxy-Authorization is forwarded intact to the redirect target, potentially exposing forward-proxy credentials to a host outside the original trust boundary when redirects are enabled through the redirects option or Wreck.defaults({ redirects: ... }). This issue is fixed in version 18.1.1.

    • Mettez à jour vers 18.1.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →