p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de @xhmikosr/decompress

Vulnérabilité publiée pour @xhmikosr/decompress au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-101894

    Critique · CVSS 9.1EPSS 0,81%Code d’exploitation publicCorrectif disponible

    @xhmikosr/decompress: Path traversal via symlink chain

    The decompress package for Node.js extracts archives. Prior to 10.2.2 and 11.1.4, the default decompress(input, output) API relies on lexical containment checks that do not account for the kernel following a planted symlink chain. An attacker can supply a crafted archive containing chained symlink entries so that a later entry resolves outside the output directory. This allows files outside output to be read or written, and overwriting startup scripts or configuration can lead to remote code execution. The maintained @xhmikosr/decompress package is fixed in 10.2.2 and 11.1.4, but the separately affected unmaintained decompress package remains

    • Mettez à jour vers 10.2.2
    • Mettez à jour vers 11.1.4
    Publication Mise à jour
  2. CVE-2026-53486

    Critique · CVSS 9.1EPSS 0,75%Code d’exploitation publicCorrectif disponible

    decompress: Archive extraction can create files and links outside the target directory

    The decompress package for Node.js extracts archives. Prior to 10.2.1 and 11.1.3, archive extraction can create files and links outside the target directory. When extracting an archive to a directory, a crafted archive can read or write files outside that directory because hardlink and symlink entries are created without checking where targets point, path containment used a string prefix comparison, and file modes failed to remove setuid, setgid, or sticky bits. This issue is fixed in @xhmikosr/decompress versions 10.2.1 and 11.1.3.

    • Mettez à jour vers 10.2.1
    • Mettez à jour vers 11.1.3
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →