p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de glob

Vulnérabilité publiée pour glob au cours des 30 derniers jours : 1. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-118773

    Moyenne · CVSS 6.3EPSS 0,35%Code d’exploitation publicCorrectif disponible

    Glob: AbortSignal cancellation bypass allows post-timeout filesystem traversal

    Glob matches files using patterns the shell uses. From 9.0.0 until 14.0.2, abort branches in src/walker.ts, including GlobUtil.walkCB(), GlobUtil.walkCB2(), GlobUtil.walkCBSync(), and GlobUtil.walkCB2Sync(), invoke the callbacks without returning. After AbortSignal or AbortSignal.timeout() rejects or emits an error, execution can continue into processor.processPatterns(), readdirCB(), and recursive traversal. The issue affects glob() and globStream() when applications expose attacker-influenced patterns or directory trees and rely on cancellation as a traversal budget. Repeated timed-out requests can stack background filesystem operations and

    • Mettez à jour vers 14.0.2
    Publication Mise à jour
  2. CVE-2025-64756

    Élevée · CVSS 7.5EPSS 3,09%Correctif disponible

    glob CLI: Command injection via -c/--cmd executes matches with shell:true

    Glob matches files using patterns the shell uses. Starting in version 10.2.0 and prior to versions 10.5.0 and 11.1.0, the glob CLI contains a command injection vulnerability in its -c/--cmd option that allows arbitrary command execution when processing files with malicious names. When glob -c <command> <patterns> are used, matched filenames are passed to a shell with shell: true, enabling shell metacharacters in filenames to trigger command injection and achieve arbitrary code execution under the user or CI account privileges. This issue has been patched in versions 10.5.0 and 11.1.0.

    • Mettez à jour vers 10.5.0
    • Mettez à jour vers 11.1.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →