p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de hummus

Vulnérabilité publiée pour hummus au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 4

  1. CVE-2022-41957

    Élevée · CVSS 7.5EPSS 1,13%Aucun correctif publié

    muhammara vulnerable to Unchecked Return Value to NULL Pointer Dereference

    Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.

    Publication Mise à jour
  2. CVE-2022-39381

    Élevée · CVSS 7.5EPSS 0,89%Correctif disponible

    Unchecked Return Value to NULL Pointer Dereference in PDFDocumentHandler.cpp

    Muhammara is a node module with c/cpp bindings to modify PDF with js for node or electron (based/replacement on/of galkhana/hummusjs). The package muhammara before 2.6.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be appended to another. This issue has been patched in 2.6.0 for muhammara and not at all for hummus. As a workaround, do not process files from untrusted sources.

    • Mettez à jour vers 1.0.111
    Publication Mise à jour
  3. CVE-2022-25892

    Élevée · CVSS 7.5EPSS 1,36%Correctif disponible

    Denial of Service (DoS)

    The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.

    • Mettez à jour vers 1.0.111
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →